argh -- can't get wireless in someone else's house

R. G. Newbury newbury at
Sat Feb 9 17:11:49 UTC 2008

> Date: Fri, 8 Feb 2008 08:44:25 -0500 (EST)
> From: "Robert P. J. Day" <rpjday at>
>   i'm embarrassed to admit that i can't, for the life of me, get a
> wireless connection at a friend's house at the moment.  updated fedora
> 8, and a stock linksys WRT54GL.  i have the SSID, i have the WEP key,
> i even have the router password, so i've logged in and checked
> everything -- no MAC filtering, no DHCP client limit, etc.
>   but when i try to bring up wireless, /var/log/messages shows me:
> Feb  8 08:37:59 localhost dhclient: wmaster0: unknown hardware address type 801
> Feb  8 08:39:00 localhost dhclient: No DHCPOFFERS received.
>   i can certainly see the WAP:
> # iwlist wlan0 scan
> Cell 02 - Address: 00:18:39:6A:01:EF
>                     ESSID:"XXXXXXXX"
>                     Mode:Master
>                     Channel:6
>                     Frequency:2.437 GHz (Channel 6)
>                     Quality=83/100 Signal level=-46 dBm  Noise level=-67 dBm
>                     Encryption key:on
>                     Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
>                               24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
>                               12 Mb/s; 48 Mb/s
>   i'm pretty much out of ideas here -- any thoughts?

Hmmm,.."No DHCPOFFERS received."
1)	DHCP server not turned on??  (You have likely checked that three 
times already!)
2)	No remaining available DHCP addresses?  This one got me: I set up for 
only two then tried a new (third) unit, forgetting that the printserver 
was using the 'spare' address.
3)	More insidious: whoever set up the Linksys turned on MAC filtering, 
so no DHCP Offer will *ever* be sent. After I fixed problem #2, it took 
me a....further...while to figure out this one. And it's kinda hidden in 
the linksys setup structure ( I use the DD-WRT BIOS on my linksys, and 
it is a little more friendly).
4)	I found that iwconfig is order dependent and sensitive to too many 
settings being tried at once. The ESSID setting has to be LAST. (Thank 
you to somone on this list!)

Eventually this chunk of script gave me repeatable connections at home 
and the office.
ifdown eth0
/sbin/service NetworkManagerDispatcher restart
/sbin/service NetworkManager restart
/sbin/modprobe ipw2200
/sbin/iwconfig eth1 mode managed
/sbin/iwconfig eth1 rate auto
/sbin/iwconfig eth1 channel 11
/sbin/iwconfig eth1 key restricted
/sbin/iwconfig eth1 key 1 thisisthe26characterhexkey
/sbin/iwconfig eth1 essid XXXYYYXXXYYY
ifup eth1
echo ""
echo ""


More information about the fedora-list mailing list