FC8/FC7: raid sata adapter doesn't work properly

jeanpca at free.fr jeanpca at free.fr
Sat Feb 9 18:14:03 UTC 2008


   I have a linux box with a motherboard ASUS TL2C with linux FC7 and  
FC8 installed. On one of the pci port, I connected a raid adapter Via  
VT6421 and I connect one or two sata disks on the sata ports given by  
this adapter.

   When linux boots, the adapter is recognized. I may enter in the  
bios, choose raid or no and when the system is booted I can see sata  
devices as sdc and/or sdd. here is the lspci output:

   02:0b.0 RAID bus controller: VIA Technologies, Inc. VT6421 IDE RAID  
Controller (rev 50)
        Subsystem: VIA Technologies, Inc. VT6421 IDE RAID Controller
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d800 [size=16]
        I/O ports at d400 [size=16]
        I/O ports at d000 [size=16]
        I/O ports at b800 [size=16]
        I/O ports at b400 [size=32]
        I/O ports at b000 [size=256]
        [virtual] Expansion ROM at efe20000 [disabled] [size=64K]
        Capabilities: [e0] Power Management version 2
        Kernel driver in use: sata_via
        Kernel modules: sata_via

   I format these/this sata disk with fdisk as follow:

   # fdisk /dev/sdc               
Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000
   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1       60801   488384001   83  Linux

and I use mkfs -j /dev/sdc1 to create the ext3 filesystem. Apparently  
it works well

   but, when I tried to label sdc1 or mount sdc1, the mountage is  
impossible and it tells me to give the FS type. In the message log  
file, I can see this message :

   kernel: EXT3-fs error (device sdc1): ext3_check_descriptors: Inode  
table for group 41 not in group (block 1310722)!
kernel: EXT3-fs: group descriptors corrupted!

I use FC7 or FC8 (Linux version and the problem is  
the same with one or several disks. But this operation worked well on  
another computer with another sata adapter and another disks.

   Could you help me on this problem ? Are you aware of issues about  
Via sata problem with linux ?

   Thanks in advance


   Jean-Philippe Battu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/fedora-list/attachments/20080209/c94e6417/attachment-0001.htm>

More information about the fedora-list mailing list