Tracking the sound problem.

Aaron Konstam akonstam at
Sun Feb 10 15:41:09 UTC 2008

On Sat, 2008-02-09 at 16:14 -0600, Aaron Konstam wrote:
> Scince no one has solved the global f8 sound problem for me let me try
> to get an answer to a part of the problem.
> The system seems to be tring to locate sound card 0.
> On my system /proc/asound/cards returns:
>  0 [CS4236B        ]: CS4236B - CS4236B
>                       CS4236B at 0x534, irq 5, dma 1&3
> or example
> Which seems to imply that the CS42368 is sound card 0. So what could be
> going wrong.
> For example, running:
> mplayer "mms://"
> Returns lines like these:
> [AO_ALSA] alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
> [AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function
> snd_func_card_driver returned error: No such device
> [AO_ALSA] alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating
> strings
> [AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function
> snd_func_concat returned error: No such device
> [AO_ALSA] alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating
> name
> [AO_ALSA] alsa-lib: conf.c:3510:(_snd_config_evaluate) function
> snd_func_refer returned error: No such device
> [AO_ALSA] alsa-lib: conf.c:3982:(snd_config_expand) Evaluate error: No
> such device
> [AO_ALSA] alsa-lib: pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM
> default
> [AO_ALSA] Playback open error: No such device
> Could not open/initialize audio device -> no sound.
> Audio: no sound
> Video: no video
> What are these errors telling me?

Well this makes no more sense than anything else but I solved one sound
problem. I changed the permissions of /dev/dsp to 666. Then:
mplayer "mms://"

works. But that is all that works and it makes no sense since on my f7
system /dev/dsp is 660.

More information about the fedora-list mailing list