Tracking the sound problem.

Mark C. Allman mcallman at
Sun Feb 10 17:57:14 UTC 2008

On Sun, 2008-02-10 at 17:16 +0100, Nigel Henry wrote:
> On Sunday 10 February 2008 06:58, Tim wrote:
> > On Sat, 2008-02-09 at 18:18 -0500, Tom Horsley wrote:
> > > Why any sane kernel startup sequence would initialize any
> > > removable devices before any fixed devices is a separate
> > > question :-).
> >
> > I can imagine one reason:  The thought that an "added on" device might
> > be to replace a built-in device that you can't remove.
> >
> > However, if I'm asked to configure what is my default sound card (as
> > during the first-boot sequence), I expect that default to stay no matter
> > what else is added.
> Hi Tim. The way I've always understood this, regarding USB devices that use 
> snd-usb-audio, is that because the USB comes up early in the boot process, 
> anything that resembles an audio device (like my usb midi keyboard), gets set 
> as card0. If your actual soundcard is aliased as card0, with the options line 
> showing "index=0", it is unlikely to show up in /proc/asound/cards, as 
> snd-usb-audio has already grabbed card0. Saying that though, you will 
> probably still see that the modules have been loaded for your actual 
> soundcard in /sbin/lsmod | grep snd, but because the soundcard isn't 
> in /proc/asound/cards, it won't work.
> The fix I've had to use since FC1, and on other distro's too, is to set alias, 
> and options lines in /etc/modprobe.conf for snd-usb-audio, as below.
> alias eth0 8139too
> alias scsi_hostadapter libata
> alias scsi_hostadapter1 pata_via
> alias snd-card-0 snd-emu10k1
> options snd-card-0 index=0
> options snd-emu10k1 index=0
> alias snd-card-1 snd-usb-audio
> options snd-usb-audio index=1
> options snd-bt87x index=2
> options bttv automute=0
> options tuner port2=0 pal=I
> install pcspkr /bin/true
> The module snd-bt87x above, is another notorious one, along with some modem 
> modules, that like to grab card0, before anything else can. It's the sound 
> capture module for my TV card, and some distro's have default options lines 
> for these problematic modules, and set them as "index=2", thus stopping them 
> grabbing card0.
> If you have more than one audio device on the USB, it get's a little more 
> complex, and you have to specify them by their PID's (product id's), and 
> VID's (vendor id's). So for example you could have your webcam, and usb midi 
> keyboard always taking the same position. I'll have to look for the exact 
> details on this, as they were on the alsa-user list.
> Just some Sunday afternoon (Northern France) passing the time stuff.
> Nigel.
As I posted earlier in the discussion thread, I have:

  [root at prez doc]# ls /proc/asound/
  card0 cards devices hwdep Intel modules oss pcm seq timers version
  [root at prez doc]# ls /proc/asound/card0
  codec#0  codec#1  id  oss_mixer  pcm0c  pcm0p  pcm1p
  [root at prez doc]# ls -l /proc/asound/Intel
  lrwxrwxrwx 1 root root 5 2008-02-10 12:42 /proc/asound/Intel -> card0
  [root at prez doc]# cat /proc/asound/cards
   0 [Intel          ]: HDA-Intel - HDA Intel
                        HDA Intel at 0xdfffc000 irq 21

Lines in /etc/modprobe.conf:
  options snd cards_limit=8
  options snd-card-0 index=0
  alias snd-card-0 snd-hda-intel
  options snd-hda-intel index=0
  alias snd-card-7 snd-usb-audio
  options snd-usb-audio index=7

When I run aplay to "list all soundcards and digital audio devices:"
  [root at prez doc]# aplay -l
  aplay: device_list:205: no soundcards found...

In the system-config-soundcard applet:
  Vendor: Intel Corp.
  Model: 82801G (ICH7 Family) High Def. Audio Controller
  Module: snd-hda-intel

There is a sound card, the VLC media player works just fine, flash audio
in Firefox doesn't, CD Player doesn't, obviously aplay doesn't, and the
system-config-soundcard sees my audio device but when I click on "play"
I don't hear anything.  I can copy a ".au" (if I remember correctly)
audio file directly to /dev/audio and I hear it.

Any ideas on what to try next would be welcome!  I've already tried
"model=" modprobe options that I see could be legal (laptop, dell-m42,
dell-3stack, etc.).

-- Mark C. Allman, PMP
-- Allman Professional Consulting, Inc.
--, 617-947-4263

BusinessMsg -- the secure, managed, J2EE/AJAX Enterprise IM/IC solution

More information about the fedora-list mailing list