LVM and grub

Timothy Murphy gayleard at eircom.net
Tue Feb 12 14:20:53 UTC 2008


Mikkel L. Ellertson wrote:

> Gene Heskett wrote:
>> On Monday 11 February 2008, Timothy Murphy wrote:
>>> Mikkel L. Ellertson wrote:
>>>> With /boot on its own partition, Grub does not need to access the
>>>> root partition. This is good because Grub does not understand LVM.
>>>> The thing you have to remember when using a separate /boot partition
>>>> is that the paths that Grub uses do not start with /boot. You would
>>>> use something like:
>>>>
>>>> title Fedora (2.6.23.14-115.fc8)
>>>>          root (hd0,2)
>>>>          kernel /vmlinuz-2.6.23.14-115.fc8 ro
>>>> root=/dev/VolGroup00/LogVol00 rhgb quiet
>>>>          initrd /initrd-2.6.23.14-115.fc8.img
>>>>
>>>> As far as Grub is concerned, your /boot directory is its root
>>>> directory. This is what the root (hd0,2) is telling Grub.
>>> My problem was that root=/dev/VolGroup00/... was not found,
>>> since LVM was not active at at that point.
>>> The boot started, but failed with "/dev/root not found".
>>>
>> Huh?  I've been booting with exactly that command line argument for quite
>> some
>> time now.  Year (how old is FC6?) or more.  Perhaps your hd(0,2) is too
>> far
>> into the disk and the bios is having problems?  One of the many reasons
>> the /boot partition is the first one here, and something in the back of
>> my mind says it cannot be a directory within an LVM, but must be a
>> separate partition.
 
> The message would be about the kernel or the initrd not being found,
> or Grub failing completely if the /boot partition was too far in.
> This sounds more like a problem with the initrd not having LVM
> support, or that root is not on VolGroup00/VolGroup00.
> 
> The output of "parted /dev/sda print" would help. So would the
> output of lvs.

Unfortunately I have deleted the LVM partitions,
created normal ones, and installed the Live CD that way, with no problems.

> According to the Grub info page, there is supposed to be a way to
> use Grub with /boot on a LVM, but you lose the ability to just edit
> the menu, or change kernels, without re-running grub-install. You
> don't use a stage 1.5 and Grub loses the ability to read the file
> system when booting. It preforms a lot like LILO does. I would not
> recommend it for the average user.

Unfortunately I could not access the system, so could not run grub-install.
I could have tried doing that through Knoppix, I guess, but I didn't.
I tried the Rescue CD, but that didn't see the system.
I also tried installing the initrd from an identical computer using LVM,
but got the error message, "Incompatible file systems".

I did consider using LILO, but decided that was too old-fashioned.
(It seemed from a brief google that this had been a solution
for some people.)

I looked briefly at the grub documentation ("info grub")
but didn't find any help there.
There didn't seem any point in trying to add a "module" line
to grub.conf , as I assume grub would not have found /lib/modules .




-- 
Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland




More information about the fedora-list mailing list