F8 Install issues on IBM A31p laptop

Wade Hampton wadehamptoniv at gmail.com
Wed Feb 13 20:06:55 UTC 2008

I really look forward to being able to use F8, however my luck is not so
good at this point.  (I am just getting to F8 as my desktops are
CentOS 5 right now).

I am having serious install and update issues with my Fedora 8 on an IBM A31p
laptop.  This has only 256M RAM but has been running Fedora Core 4 for years!

An update from FC4 to F8 failed (I gave up after 3 hours).  I would expect it to
either fail or try, but not to hang working for hours.... In the past,
I have reported
very, very long update times from one Fedora to another (for example a laptop
at home going from FC5 -> FC6 took 16 hours).  I had hoped this was fixed....

Next, I tried an install, reformatting /boot and / (kept my data partitions and
/home).  The installer failed several times on package 1000 or so of 1200+
packages.  On both tests, I had selected desktop packages + development
packages + some other misc. packages.

The installer also failed when I added in my IBM recover VFAT partition
to the mount list.

  - I hope these issues have been resolved in anaconda....
  - All installs were using the recover CD using hard disk install with
    the install DVD stored as an image on my hard disk.

I finally selected just desktop, minimal partitions, etc., and F8 installed!

During install, my USB mouse (Logitech optical wireless) was stuttering, but the
internal trackpoint worked.  Each time I moved it, it would pause, then jump.

On the first boot, the USB mouse still stuttered and networking (e100) failed.
I removed and reinstalled the e100 module, tried static IP, etc., but networking
remained down (yet dmsg showed the NIC was up).  I had to reboot yet again.

Once it was loaded and booted, the NIC and mouse worked!

However, yum update failed with an error "out of memory".  I then updated
just openoffice - this worked.  I next tried doing a full yum update again.
Again it failed, hanging the computer several times.

After a reboot, a yum update would report that the yum lock still existed.
Should the yum lock (/var/run/yum.pid) be cleaned out on a boot?
One time YUM failed with
  "OSError: [Errno 2] No such file or directory:

I am now trying to update in pieces but I keep getting missing files,
  yum update firefox:
    Package yelp needs gecko-libs =, this is not available.
  yum update
    Error: Missing Dependency: gnome-python2 = 2.20.0-1.fc8 is needed
by package gnome-python2-bonobo

I am now partially updated (kernel, openoffice, etc.).  I have yet to
install development packages, etc.  This is getting very frustrating.

Yum mirrors should be left in a consistent state so you don't get
problems like this (very difficult for newbies or someone who
is not familiar with yum).  I have had this problem for years as well.

Any help would be most appreciated.  Sorry for the long-winded mail...
Wade Hampton

More information about the fedora-list mailing list