So, What is the best way to upgrade an FC6.i686 to F8.x86_64

Kevin J. Cummings cummings at
Mon Feb 18 03:47:49 UTC 2008

I've just finished an aborted attempt to install FU 20070204 8 X86_64 on
my laptop, currently running an FC6.i686 installation.

The media passes the media check on the DVD.

Try #1:  I tried the "upgrade" option.  Anaconda tells me that this
method is not supported and may fail since I am changing architectures.

Try #2:  I tried the "install" option.  I left the disk partitioning
alone, and tried to install on top of my current installation.  I choose
to add "Software Development" on top of the default "Office and
Productivity" selection.  Things went well until it checked the
trasaction.  Seems the compiz.i386 from FC6 conflicts with the
compiz.x86_64 from F8.   Hmmm, I didn't think this was supposed to
happen.  More may have conflicted, but that's all I could get from the
truncated F4 console.  So, I rebooted FC6, and did an "rpm --erase
compiz".  After it finished erasing, I tried again.

Try #3:  I tried again, this time anaconda bags out with an error
message, and leaves an anacdump.txt file in my /root directory.

So, I seem to be stuck, furthermore, my laptop is not exactly the same
as before the attempt anymore.  NetworkManager can't find my wireless,
and the RHGB stuff seems to be gone.  I've had to hook the ethernet
cable to get "connected" again.  I'm not sure what else is "broken".
VMWare seems to be OK, and X11 is still working, but some of my sensors
are complaining about my hard disk, so I disabled that sensor for the
time being.

So, what did I do wrong, and how do I fix it?

BTW, my disk is essentially partitioned into a single "/" partition, and
I'm interested in losing my local data in /home by re-formatting....or
by losing the list of all of my installed RPMs (so I can re-create my
system after the architecture change).

Kevin J. Cummings
kjchome at
cummings at
cummings at
Registered Linux User #1232 (

More information about the fedora-list mailing list