Video interference & slow running solved but...

Frank Cox theatre at
Tue Feb 19 22:56:09 UTC 2008

I seem to have solved a problem and created a new one.

I got an ATI X1550 video card and set that up to use the DVI output to my
monitor instead of the analog VGA that I had off of the built-in Intel video.
To my surprise, that seems to have got around the issue of that Intel bios bug
causing the huge slowdown on this computer (see the "s-l-o-w installation"
thread that I started the other day. I don't need to specify any "mem=" kernel
parameter any more; it just works at full speed without any problem.

In addition, this seems to have solved the problem of the interference lines on
my display -- I haven't seen one so far since I put this card in.


I can't manage to get 1680x1050 video resolution.  "Out-of-the-box" I got
1400x1050, which looks squashed.  I tried fiddling around with xorg.conf by
specifying the modeline and resolution that I want.  This is what I ended up

# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us+inet"

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Acer 2223W"
        DisplaySize     474     296
Modeline "1680x1050" 149 1680 1784 1960 2240 1050 1053 1059 1089

Section "Device"
	Identifier  "Videocard0"
	Driver      "vesa"

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	Modes   "1680x1050" "1280x1024"

This made it worse because all I get is 1280x1024 using this xorg.conf.  I
copied what appeared to be the relevant lines from the xorg.conf file that I had
made for Fedora 7 and the Intel video chipset a while back when I first got this
widescreen monitor.  Obviously, I've missed something somewhere.

I would like to get this going without having to install the proprietary ATI
driver, if I can.

So... what can I do now?

MELVILLE THEATRE ~ Melville Sask ~

More information about the fedora-list mailing list