best way to upgrade an FC6.i686 to F8.x86_64 - don't - fresh install instead.

Craig White craigwhite at
Wed Feb 20 03:03:19 UTC 2008

On Tue, 2008-02-19 at 21:46 -0500, Ric Moore wrote:
> On Sun, 2008-02-17 at 22:47 -0500, Kevin J. Cummings wrote: 
> > I've just finished an aborted attempt to install FU 20070204 8 X86_64 on
> > my laptop, currently running an FC6.i686 installation.
> > 
> > The media passes the media check on the DVD.
> > 
> > Try #1:  I tried the "upgrade" option.  Anaconda tells me that this
> > method is not supported and may fail since I am changing architectures.
> > 
> > Try #2:  I tried the "install" option.  I left the disk partitioning
> > alone, and tried to install on top of my current installation.  
> Without formatting? Old FC6 install intact? <giggles inanely> and you
> hope to do what? Mix FC6 i386 with FC8 X86-64? AND have it all work?
> I'll read on... with great interest. 
> > I choose
> > to add "Software Development" on top of the default "Office and
> > Productivity" selection.  Things went well until it checked the
> > trasaction.  Seems the compiz.i386 from FC6 conflicts with the
> > compiz.x86_64 from F8.   Hmmm, I didn't think this was supposed to
> > happen.  More may have conflicted, but that's all I could get from the
> > truncated F4 console.  So, I rebooted FC6, and did an "rpm --erase
> > compiz".  After it finished erasing, I tried again.
> God only knows what FC6-i386 config, libraries and binary files are
> lying around. I gotta admit, this is a novel approach. But, you're also
> whacking the system in the small berries by changing arch AND installing
> practically another OS on top of another one. 
> I'd suggest to Rahul we name this the "Michael Vick" install method.
> Just toss F8 x86-64 in the machine and throw rocks on it to make it boot
> up fighting mean. Make FC8 fight whatever else it meets, like a Pitbull.
> If it doesn't win, you could always strangle it. 
> > Try #3:  I tried again, this time anaconda bags out with an error
> > message, and leaves an anacdump.txt file in my /root directory.
> > 
> > So, I seem to be stuck, furthermore, my laptop is not exactly the same
> > as before the attempt anymore.  
> It is exhausted from the schizophrenia experience and may be traumatized.
> > I've had to hook the ethernet
> > cable to get "connected" again.  I'm not sure what else is "broken"
> > VMWare seems to be OK, and X11 is still working, but some of my sensors
> > are complaining about my hard disk, 
> If you could look inside it, you'd see the face from "The Scream",
> whirring around at 7200rpm.
> > so I disabled that sensor for the
> > time being.
> That'll teach it a damn lesson...
> > So, what did I do wrong, and how do I fix it?
> Jus' kidding. Backup critical data, install fresh after a re-format to
> wipe the drive clean, before changing arch. Use low tones and tell it
> you'll never do that again ...softly with deep concern. ;) Ric
I suspect that many of us were the type to stick our fingers in the fan
anyway, despite what our moms said.

Obviously, the only sane theory of a good running system would be to
back up the data, wipe and clean install but there are some who will try
to stop the fan with their fingers anyway and that of course is the
beauty of Linux.

Most of us tend to gape at the wrecks on the highway fully knowing that
a quick look could make us ill. In that spirit, I hope that Kevin checks
in on his efforts so I can amuse myself at the carnage or marvel at his
administrative skills for his execution of the 3 Card Monty.


More information about the fedora-list mailing list