GNome hang

Peter J. Stieber developer at
Wed Feb 20 17:02:13 UTC 2008

PS = Pete Stieber wrote:
PS>> My X-server hangs after running for a few minutes.
PS>> I run gnome.  The mouse continues to move on the
PS>> screen, but the keyboard dies and the clicking the
PS>> mouse has no effect.
PS>> I can ssh into the machine and  kill a ton of
PS>> processes to exit out of the XServer.
PS>> I have an ATI graphics card...
PS>> # lspci
PS>> .
PS>> .
PS>> .
PS>> 05:00.0 VGA compatible controller:
PS>> ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
PS>> I am not using any third-party drivers.
PS>> I upgraded this box from 6 -> 7 -> 8.  I recently
PS>> learned about the fedora yum upgrade FAQ.
PS>> For a 7 -> 8 upgrade, the FAQ recommends...
PS>> # yum groupinstall sound-and-video gnome-desktop
PS>> When I try this I get the text appended to this message.
PS>> Sorry about the line-wrap.
PS>> What should I do next?
PS>> Pete
PS>> fedora          100% |=========================| 2.1 kB    00:00
PS>> updates         100% |=========================| 2.1 kB    00:00
PS>> Setting up Group Process
PS>> Package alsa-utils - 1.0.15-1.fc8.x86_64 already installed and latest
PS>> version

RE = Richard England
RE> This is not really an answer but perhaps a place for
RE> some further investigation.  I had a system with an
RE> nvidia card that exhibited the same symptoms you are
RE> describing.  I isolated it to some interaction with
RE> one of a set of screen savers and the video driver.
RE> If I stopped using the screen savers I no longer had
RE> the problem.  If I changed to the vendor drivers I
RE> didn't have the problem.  Before I could do any
RE> more investigation I ran an update on the system,
RE> which included a new kernel and video drivers and
RE> the problem was gone.
RE> It might be worth investigating the video systems
RE> and the screen savers.
RE> HTH, sorry I don't have a real "solution" for you.

I'm pretty sure this isn't related to screen savers because I am using 
the display (moving the mouse and hitting keys on the keyboard) when the 
X server gets bogged down.

I removed a bunch of packages using "yum erase".  I finally got to a 
point where "yum groupinstall gnome-desktop" worked.  I also noticed a 
recent update to the Fedora ATI xorg drivers, but I'm still experiencing 
the hang.  Now I don't have any mouse or keyboard.  The caps lock, 
scroll lock, num lock leds don't change when I hit these keys.

When I login remotely, top tells me that the xserver process (X) is 
using 100% of cpu.

I can post my Xorg.0.log, but it is large (59,684) and I don't see any 
errors in it.  There are warnings.

What should I do next?


More information about the fedora-list mailing list