Fedora 8: tcsh .history file destroyed on exit?

James Frye fryeja at us.ibm.com
Thu Feb 21 17:52:04 UTC 2008


I've just installed Fedora 8 on a new machine (Lenovo T61p), and am having
problems getting
tcsh to run correctly.  The main problem is that when I exit, the .history
file is destroyed.  It's
not that the current session history is not saved.  I copied a .history
file from my older machine
loaded it, and the history mechanism works as expected for that session.
On restart, though,
I find that the .history file has been truncated to 0 bytes.

I have two perhaps related other problems.  First, tcsh was not installed
by the install system.  I
had to compile it from source.  Second, the root user does not source
its .tcshrc file when I su
or log in as root.  I have to do this manually.

If it helps, I run xterm under the fvwm2 window manage, and am using a
system setup that was
copied from the Fedora 7 install on my previous machine, and which have
worked with various
Fedora versions going back to 3 (IIRC), as well as other distros.


More information about the fedora-list mailing list