Fedora 8: tcsh .history file destroyed on exit?

Phil Meyer pmeyer at themeyerfarm.com
Thu Feb 21 18:29:29 UTC 2008

James Frye wrote:
> Hi,
> I've just installed Fedora 8 on a new machine (Lenovo T61p), and am having
> problems getting
> tcsh to run correctly.  The main problem is that when I exit, the .history
> file is destroyed.  It's
> not that the current session history is not saved.  I copied a .history
> file from my older machine
> loaded it, and the history mechanism works as expected for that session.
> On restart, though,
> I find that the .history file has been truncated to 0 bytes.

This has been the default behavior for tcsh for many years.  I can't 
even remember what year that changed ...

Check your .tcshrc -- your savehist may not be correct:  here is mine:

        set history=999
        set savehist=900 merge

> I have two perhaps related other problems.  First, tcsh was not installed
> by the install system.  I
> had to compile it from source.  Second, the root user does not source
> its .tcshrc file when I su
> or log in as root.  I have to do this manually.
As another has suggested:

# yum install tcsh

It may not be a good idea to set root's shell to tcsh, since many 
processes executed as root may depend on bash syntax.

Having installed from source, the tcsh binary may have the wrong 

 -> ls -l /bin/tcsh
-rwxr-xr-x 1 root root 351528 2007-08-31 03:39 /bin/tcsh*

Or may have been built with less than optimal 'configure' arguments.
> If it helps, I run xterm under the fvwm2 window manage, and am using a
> system setup that was
> copied from the Fedora 7 install on my previous machine, and which have
> worked with various
> Fedora versions going back to 3 (IIRC), as well as other distros.

Good luck!

More information about the fedora-list mailing list