ATI DRIVER installation problems - asking for help.

bravo_elf bravo.elf at
Tue Feb 26 20:07:21 UTC 2008

Hello guys!

Ok that's my story (its a little bit long but describes all the

Once upon a time I decided to install ATI driver on my Acer TravelMate
4602WLMI, which works with ATI Mobility Radeon X600.

So I went to ATI site and downloaded linux driver for my FC8.

I installed it on my laptop, but something got wrong, as I can remember the
problem was caused by version of kernel, it wasn't suitable or
something like that.

Since I'm new to linux and don't know how handle that kind of stuff I've decided
simply to remove it from laptop and look around for some easier way
of installation.

I found this site:

Which explains how exactly I can do it:

"yum install kmod-fglrx"

and then enable 3D support:

"init 3"
"fglrx-config-display enable"

The process has started and at the end yum returned me a message:
"Error: ati-x11-drv conflicts with xorg-x11-drv-fglrx"

At this point some feeling of "not completely un-installed previous
driver" started to rise inside me.

That feeling  made me to check if there some files (packages) left at
the system. After checking my yumex I found a "xorg-x11-drv-ati"
package, and removed it. At this point the "catch" appeared.
Yum has removed not only "xorg-x11-drv-ati" but "xorg-x11-drivers"
Somehow it looked nice to me cause my thought was:"now I haven't any
package that can interfere my installation.

I rebooted my laptop and got into "init 3" black screen. Of course I
saw the message that told about "no x11 drivers installed".

I tried "yum install kmod-fglrx" command one more time, and was very
surprised when I saw the same error about driver confrontation.

So now I have init 3 mode for work and have no ATI driver installed

Please if anyone knows how fix this issue I will be glad to hear the

Also if you don't mind, I would like to know which steps (that I made)
were lame. Where did I wrong?



mailto:bravo.elf at

More information about the fedora-list mailing list