Help with a little dd damage!

Morgan Read mstuff at
Wed Feb 27 09:05:28 UTC 2008

Hi Folks

This post could equally be titled - is there a God?

Yesterday I ran this command:
[root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda of=pocketpc.rescue 
bs=1M count=33
(No output, just bash history.)

Today I ran these commands:
[root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda of=2ndstage.rescue 
bs=1K count=1280
1280+0 records in
1280+0 records out
1310720 bytes (1.3 MB) copied, 0.0535238 s, 24.5 MB/s
[root at morgansmachine DiskBUImagesEtc]# chown morgan: ./2ndstage.rescue
[root at morgansmachine DiskBUImagesEtc]# dd 
2348+0 records in
2348+0 records out
1202176 bytes (1.2 MB) copied, 0.117155 s, 10.3 MB/s
[root at morgansmachine DiskBUImagesEtc]#

Both yesterday and today I should not have used /dev/sda, but should 
have used /dev/sdc...  Ouch...

Now I seem to have an unallocated partition of some 37.26GB where once 
existed my carefully constructed laptop hard drive.

Everything seems to be running fine, but I expect if I reboot - I wont! 
  I guess I've just wiped out my MBR or something close.

So, fingers firmly crossed, have I managed to copy enough of my hard 
drive with the first two commands to be able to patch back the 
catastrophic damage I seem to have done with the last command.  Could 
someone more confident than I give me some instruction:)

Any help desperately welcome.

Getting errors: "There are problems with the signature" (or similar)?
Update your system by installing certificates from CAcert Inc, see here:
Or, if Internet Explorer is your default browser, simply click this link:

Morgan Read

fedora: Freedom Forever!

"By choosing not to ship any proprietary or binary drivers, Fedora does
differ from other distributions. ..."
Quote: Max Spevik

RMS on fedora:

More information about the fedora-list mailing list