Help with a little dd damage!

Ian Malone ibmalone at
Wed Feb 27 09:42:29 UTC 2008

Morgan Read wrote:
> Hi Folks
> This post could equally be titled - is there a God?
> Yesterday I ran this command:
> [root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda of=pocketpc.rescue 
> bs=1M count=33
> (No output, just bash history.)

> Today I ran these commands:
> [root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda of=2ndstage.rescue bs=1K count=1280
> 1280+0 records in
> 1280+0 records out
> 1310720 bytes (1.3 MB) copied, 0.0535238 s, 24.5 MB/s
> [root at morgansmachine DiskBUImagesEtc]# chown morgan: ./2ndstage.rescue 
> [root at morgansmachine DiskBUImagesEtc]# dd 
> of=/dev/sda
> 2348+0 records in
> 2348+0 records out
> 1202176 bytes (1.2 MB) copied, 0.117155 s, 10.3 MB/s
> [root at morgansmachine DiskBUImagesEtc]#
> Both yesterday and today I should not have used /dev/sda, but should 
> have used /dev/sdc...  Ouch...
> Now I seem to have an unallocated partition of some 37.26GB where once 
> existed my carefully constructed laptop hard drive.

> So, fingers firmly crossed, have I managed to copy enough of my hard 
> drive with the first two commands to be able to patch back the 
> catastrophic damage I seem to have done with the last command.  Could 
> someone more confident than I give me some instruction:)

Confidence is a function of this not being my drive, however
today's 2ndstage.rescue is 1280K, compared with the 1174K you
dropped on sda.  A chunk this big may reach into the file
system structures too; remount any filesystems near the start
ro (readonly) then dd the 2ndstage rescue back.  Preferably
$ dd if=2ndstage.rescue of=/dev/sda bs=1K count=1174
to avoid writing over anything you don't have to.

This may or may not get you back where you were.  It is unlikely
to make the situation worse but nothing's impossible.

Hope that since the commands were consecutive not much has
happened in the meantime.


More information about the fedora-list mailing list