ATI DRIVER installation problems - asking for help.

bravo_elf bravo.elf at
Wed Feb 27 15:32:46 UTC 2008

Hello Heitor,

Wednesday, February 27, 2008, 6:35:12 AM, you wrote:

> xorg-x11-drv-fglrx is provided by livna and works together with
> kmod-fglrx (livna too).

> I'm using this driver without any problem.

> Let's try this:

> 1) Look at /etc/yum.repo.d/ to see your active repositories;

> 2) You won't have any conflict using only base, updates, adobe, google
> and livna; (enough for 95% of Fedora users)

> 3) Use "rpm -qa|grep -i ati" to list all packages with "ati" tag and
> remove anything that looks like a ATI driver;

> 4) Reinstall fglrx and pay attention if the packages really came from livna.

> On Tue, Feb 26, 2008 at 5:07 PM, bravo_elf <bravo.elf at> wrote:
>> Hello guys!
>>  Ok that's my story (its a little bit long but describes all the
>>  picture):
>>  Once upon a time I decided to install ATI driver on my Acer TravelMate
>>  4602WLMI, which works with ATI Mobility Radeon X600.
>>  So I went to ATI site and downloaded linux driver for my FC8.
>>  I installed it on my laptop, but something got wrong, as I can remember the
>>  problem was caused by version of kernel, it wasn't suitable or
>>  something like that.
>>  Since I'm new to linux and don't know how handle that kind of stuff I've decided
>>  simply to remove it from laptop and look around for some easier way
>>  of installation.
>>  I found this site:
>>  Which explains how exactly I can do it:
>>  "yum install kmod-fglrx"
>>  and then enable 3D support:
>>  "init 3"
>>  "fglrx-config-display enable"
>>  "reboot"
>>  The process has started and at the end yum returned me a message:
>>  "Error: ati-x11-drv conflicts with xorg-x11-drv-fglrx"
>>  At this point some feeling of "not completely un-installed previous
>>  driver" started to rise inside me.
>>  That feeling  made me to check if there some files (packages) left at
>>  the system. After checking my yumex I found a "xorg-x11-drv-ati"
>>  package, and removed it. At this point the "catch" appeared.
>>  Yum has removed not only "xorg-x11-drv-ati" but "xorg-x11-drivers"
>>  too.
>>  Somehow it looked nice to me cause my thought was:"now I haven't any
>>  package that can interfere my installation.
>>  I rebooted my laptop and got into "init 3" black screen. Of course I
>>  saw the message that told about "no x11 drivers installed".
>>  I tried "yum install kmod-fglrx" command one more time, and was very
>>  surprised when I saw the same error about driver confrontation.
>>  So now I have init 3 mode for work and have no ATI driver installed
>>  Please if anyone knows how fix this issue I will be glad to hear the
>>  answer.
>>  Also if you don't mind, I would like to know which steps (that I made)
>>  were lame. Where did I wrong?
>>  Sincerely,
>>  Ivan.
>>  mailto:bravo.elf at
>>  --
>>  fedora-list mailing list
>>  fedora-list at
>>  To unsubscribe:

Ok then... I tried all that you said, but with no changes, I got the
same error.

1) At "/etc/yum.repos.d/ I found these files:


I've removed these:

2) Futhermore I checked the "rpm -qa|grep -i ati" and found nothing,
only these packages were present:


That's all I have.

I tried "yum install kmod-fglrx" once more and got the same message.

Have any ideas?


mailto:bravo.elf at

More information about the fedora-list mailing list