ATI DRIVER installation problems - asking for help.

Heitor Moraes heitor.moraes at
Wed Feb 27 17:16:24 UTC 2008

Let's go!

I'm not a native english speaker [=brazilian], so something can look
strange, but i'll give my best.

>  Ok then... I tried all that you said, but with no changes, I got the
>  same error.
>  1) At "/etc/yum.repos.d/ I found these files:
>  adobe-linux-i386.repo
>  atrpms.repo
>  planetccrma.repo
>  rpmforge.repo
>  I've removed these:
>  fedora-updates.repo|atrpms.repo|jpackage.repo|livna-devel.repo|livna-testing.repo|planetccrma.repo|rpmforge.repo

Every .repo file is a text file.
If you created then, thats ok.
If you don't know why atrpms, planetccrma or rpmforge are at
/etc/yum.repos.d, you have a problem.

Let's try fedora.repo:

You will find 3 sections, the first section is [fedora] and is enabled
To remove a repo, you need to set enabled=1 in every section you are disabling.
But "don't remove the files".

This repo files comes with Fedora:


Some unofficial .rpm packages from atrpms, livna or
will give you additional .repo files.

The Unofficial Fedora FAQ will give you:


I suppose you have installed them with this line [from fedorafaq]:

# rpm -Uvh

I really don't like this approach, because this repos, sometimes,
don't work together.

To clear this, remove the package "yum-fedorafaq" installed from
Or this file will be garbage inside you RPM database.

To repair livna and fedora repos [specially fedora-updates], download
and reinstall the following packages:

The default configurations will activate only livna, fedora (aka base)
and fedora-updates (aka updates).
Without any testing repository.

>  2) Futhermore I checked the "rpm -qa|grep -i ati" and found nothing,
>  only these packages were present:
>  startup-notification-devel
>  konversation
>  tomcat-native
>  krb5-workstation
>  startup-notification
>  lohit-fonts-gujarati
>  gutenprint-foomatic
>  liberation-fonts
>  foomatic
>  That's all I have.

So, there is no freak unofficial ati driver.
Do the same for fglrx driver.

# rpm -qa|grep fglrx

And remove them.

Now that you removed all this strange repositories, let's repair this
with the original ati package and X11 drivers.

# yum install xorg-x11-drv-ati xorg-x11-drivers

!!! I said to remove anything that looks like an ati driver, because
you removed the original driver, but now, repair the original driver
won't give us any problem because the packages came only from Fedora
or Livna - so we can trust.

You will know if a file is the original, if a command like the
following return "Vendor: Fedora Project":

# rpm -qi xorg-x11-drv-ati

I suppose that know we have repaired every problem created by this
repos together.
And restored any original driver from your Fedora installation.

Let's install the proprietary "fglrx" from livna:

# yum install xorg-x11-drv-fglrx kmod-fglrx

You will find additional informations about livna drivers here:

>  I tried "yum install kmod-fglrx" once more and got the same message.

I've never created a rpm package from ATI installer nether used any
pre-compiled driver other than livna or old atrpms.
I suppose that after this lines you will have a clear installation of
Fedora original X11 drivers and livna together.

More information about the fedora-list mailing list