cannot set speed to 1000/FD

Steven C. Liu sliu at
Fri Feb 29 22:25:35 UTC 2008

David Timms wrote:
> Steven C. Liu wrote:
>> I recently replaced a FE 3Com card in my Linux server (hostname is 
>> imladris) with a Netgear GigE card.  I am unable to set it to 1000FD, 
>> no matter what I do.  I tried forcing it using 'ethtool -s', and 
>> setting autoneg off and on.  Rebooting didn't help.  Using a 
>> different port on my GigE switch/hub didn't help.
>> BTW - I also put a duplicate Netgear GigE card into another Linux 
>> server (hostname is numenor; additional NIC, not a replacement -- if 
>> it  matters).  On numenor, that NIC is at 1000FD.
>> I have not yet tried swapping the port and ethernet cable between 
>> imladris and numenor...
> That would be a great first check - eliminate everything you can.
> Are you using a cable with all 4 pairs correctly wired {for 1Gb}, 
> whereas only two pair {for 100Mb} ?
> Are you using a switch ? If not the crossover has to crossover 4-pairs 
> correctly !
> Is it a reasonable distance ? proper cat 6 cable ?
> DaveT.

Thanks to Mr. Timms and one other gentleman for responding...

My problem was indeed due to using a very old cable.  I don't have any 
cat 6 cables, but I found that cat 5e cables work well enough for me.  
In due time, I will likely eliminate my older cables and replace them 
with cat 6.  But, that is a project for a different day.


More information about the fedora-list mailing list