Solved: unable to allocate pty when ssh to Fedora 6 nfsroot

vincenzo romero new2xen at
Fri Feb 29 23:39:19 UTC 2008

The problem I reported below was caused by not having the devpts
mounted in my /etc/fstab.  When I created my NFSROOT, I edited the
fstab to place the nfs-mounted root line;  and in doing so the special
mounts - /proc, /sys, /dev/pts were also removed.

by adding the following in my /etc/fstab, I was then able to ssh ....
(doh, obviously it is able to create the necessary /dev/pts/0 ...
device file):

devpts                  /dev/pts                devpts  gid=5,mode=620  0 0

- V.

On Fri, Feb 29, 2008 at 2:12 AM, vincenzo romero <new2xen at> wrote:
> Hello all,
>  I am unable to ssh into a diskless host running Fedora.  When I boot
>  into the golden image (same kernel and root files), I can ssh.
>  Perhaps I'm missing something?
>  Description:  Fedora 6 - kernel: which I recompiled in
>  order to make the necessary kernel changes to support NFSROOT.
>  Problem:  The host boots ok via PXE as expected.  I can login into the
>  host via tty.  Attempts to ssh from another host causes it to hang.  I
>  checked its /var/log/secure message and found the following:
>  Feb 28 17:55:09 localhost sshd[2964]: Accepted password for sofia from
> port 36123 ssh2
>  Feb 28 17:55:09 localhost sshd[2964]: error: openpty: No such file or directory
>  Feb 28 17:55:09 localhost sshd[2966]: error: session_pty_req: session
>  0 alloc failed
>  1.  I also tried to ssh to localhost on the machine, it hangs too.
>  2.  I looked at the /dev/pts - and I notice that nothing is created there.
>  3.  I boot into the golden image running same kernel but root is on
>  disk.  I can successfully ssh into this box; and notice that when
>  ssh'ing the /dev/pts/0 directory(ies) are created appropriately.
>  4.  As I googled further ... I stumbled into a suggestion to perform
>  the following:
>  ssh <host> bash -i
>  I performed this, and I am able to ssh into the box:
>  [sofia at test1 tmp]# ssh bash -i
>  sofia at's password:
>  [sofia at localhost ~]# ls -al
>  total 200
>  ....
>  Any thought?  Perhaps I'm missing something obvious ... I will also
>  post this question in an ssh list.
>  Thanks in advance.
>  --
>  best,
>  Vince



More information about the fedora-list mailing list