[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 4L-gui problem



On Tuesday 01 January 2008, Marc Wilson wrote:
>On Sun, Dec 30, 2007 at 12:04:46AM -0500, Gene Heskett wrote:
>> [root coyote opt]# 4L-cli enumerate
>
>I note that after updating to the latest available lightscribe support
>package, and the latest copy of 4L, now *I* get:
>
>dell $ 4L-cli enumerate
>Using /etc/lightscribe.rc
>Drive path: /dev/sr1
>Usable: 1
>Full name: TSSTcorp CD/DVDW SH-S183L SB02 129
>Model: CD/DVDW SH-S183L
>Manufacturer: TSSTcorp
>Capabilities: monochrome
>Drive inner radius: 21700
>Drive outer radius: 59000

So do I once udev was convinced to make a /dev/sr0, it looks like this now:
[root coyote linux-2.6.24-rc6]# 4L-cli enumerate
Using /etc/lightscribe.rc
Drive path: /dev/sr0
Usable: 1
Full name: LITE-ON DVDRW SHM-165H6S HS06 122
Model: DVDRW SHM-165H6S
Manufacturer: LITE-ON
Capabilities: monochrome
Drive inner radius: 21700
Drive outer radius: 58700

>Where I used to get the same thing as you, Gene.
>
>I also note that now I have:
>
>dell $ ls -l /dev/sr?
>brw-rw----+ 1 mwilson disk 11, 0 2007-12-30 12:20 /dev/sr0
>brw-rw----+ 1 mwilson disk 11, 1 2007-12-30 12:20 /dev/sr1
>[ 6:53 pm][pts/1][/home/mwilson]
>dell $ ls -l /dev/scd?
>lrwxrwxrwx 1 root root 3 2007-12-30 12:20 /dev/scd0 -> sr0
>lrwxrwxrwx 1 root root 3 2007-12-30 12:20 /dev/scd1 -> sr1
>
>So udev has changed *something* recently.  I admit I hadn't actually messed
>with Lightscribe since my upgrade from FC6 to F7, which removed the support
>libraries... reinstalled them and the applications last night.
>
>Don't know when the sr[n] <-> scd[n] behavior might have changed.

Me either, and I haven't done anything to udev, but did build another kernel 
with much of the disk related stuffs built in, and now it works as expected.  
And /dev/sr0 and /dev/scd0 have the same major,minor.

[root coyote linux-2.6.24-rc6]# ls -l /dev/sr0 /dev/scd0
brw-rw---- 1 root disk 11, 0 Jan  1 20:27 /dev/scd0
brwx------ 1 root root 11, 0 Jan  1 20:27 /dev/sr0

but different perms?  Odd. Not softlinks & I just rebooted, I had a remote X 
session freeze the system, even stopped the titlebar clock.  I have GOT to 
trace that down somehow.  My shop box 150 feet away is also frozen I think, I 
haven't tried to ssh into it since rebooting.  So I'll have to go out in the 
snow and reboot it too.  Damn I hate that...  Humm, no, it appears my 
rebooting here must have killed the process out there.  Might have left stale 
locks though.

>Versions:
>
>4L-1.0-r6
>lightscribeApplications-1.10.19.1-0 (this is SimpleLabeler)
>lightscribe-1.10.27.1-0
>
Same as here now.

>and...
>
>udev-116-3.fc7
>
>This is all on F7, obviously.

udev-095-17.fc6 here.

F8 will get put together here when I get a sata card with a fscking bios 
enabled.  First pass failed, we should blacklist the Masscool XWT-RC018 card 
because of that.  The linux drivers work just fine, but you can't boot from a 
drive the bios cannot see.
 
>> Greg, this is an uptodate FC6 x86 system running 2.6.24-rc6 configured for
>> all libata drive access, so everything is scsi now if that helps.
>
>So not a Fedora kernel.  Wonder if that's relevant.

Probably.  Definite maybe at least. :)

>--
> Marc Wilson |     CONGRATULATIONS!  Now should I make thinly veiled
> msw cox net |     comments about DIGNITY, self-esteem and finding TRUE
>
>             |     FUN in your RIGHT VENTRICLE??



-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
* UNIX is a Trademark of Bell Laboratories.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]