[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum again



On Fri, 2008-01-04 at 16:23 -0800, Dave Stevens wrote:
> You know when yum works its great but every once in a while it just sets my 
> teeth on edge by failing for no apparent reason and without any noticeable 
> diagnostic. This happened recently. I tinkered with the HD and had to cycle 
> power to do so. F7 came back up saying I have updates available. As usual I 
> just entered the root password and hit enter. segfault. WTF? try again while 
> crossing my fingers and wishing. segfault. Anyone else seeing this? two 
> replies, no, must be you, works for me. grump. Dig into past fedora-list mail 
> for ideas. What about yum clean all? Looks reasonable, ran it and it returned 
> pretty quickly with no errors. Ok, will the update work? no. Now it hangs 
> after downloading the packages and before installing. Reboot. no joy. well 
> what else is in the archives. what about 
> 
> [root localhost ~]# rpm --rebuilddb
> 
> seems like a reasonable move but it has been running now for 90 minutes. Is 
> that reasonable? anyone have ideas? diagnostics? or log files I can check?
----
seems 90 minutes to rpm --rebuilddb is longer than it should take. You
could abort. Probably could 'rm /var/lib/rpm/__db*' and then 'rpm
--rebuilddb'

Then you might try 'yum clean all' to get back to square one

Craig


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]