[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: user failures



On Saturday 05 January 2008, Craig White wrote:
>On Sat, 2008-01-05 at 22:58 -0500, Gene Heskett wrote:
>> On Saturday 05 January 2008, John Summerfield wrote:
>> >Gene Heskett wrote:
>> >> Greetings;
>> >>
>> >> I had my boot drives partition table zeroed out last night by something
>> >> unk, and then X froze.
>> >
>> >Coincidentally, I've just had a kubuntu system destroy itself. It was
>> >installed as 7.04, upgraded to 7.10.
>> >
>> >Much to my astonishment, the system (cheap ASUS mobo, socket-A CPU, via
>> >chipset, generic) can suspend and hibernate, and power up on keypress.
>> >
>> >As best I can figure it, this is the sequence of events.
>> >
>> >I powered down, presumably using the new-found hibernate ability.
>> >
>> >I booted, chose a XEN-capable kernel. It might have been a 7.04 kernel,
>> >I couldn't see one obviously for 7.10.
>> >
>> >I shut down.
>> >
>> >I booted, chose the latest (non-XEN) kernel.
>> >
>> >It resumed!
>> >
>> >I used it for a time.
>> >
>> >I shut down.
>> >
>> >I rebooted.
>> >
>> >Now, we have a complicating factor: I use VGA=791, but with this kernel
>> >framebuffer does not work so I'm booting blind: nothing to see until X
>> >starts.
>> >
>> >Anyway, Nothing visible happened for a long time.
>> >
>> >I reset, then booted with VGA=6.
>> >
>> >System booted for manual fsck.
>> >
>> >I thought unkind thoughts about people who write fsck programs whose
>> >reports and messages are entirely incomprehensible to all but the
>> >highest of high priests, and ran
>> >e2fsck -y /dev/hda6
>> >
>> >There were lots and lots of messages about blocks being zeroed and/or
>> >freed and e2fsck restarting.
>> >
>> >Eventually, it finshed and ^D lead to a reboot.
>> >
>> >Later, I ran cfdisk to see what the partition table is, for reasons
>> >nothing to do with the above problems.
>> >
>> >cfdisk declined to do anything, but fdisk is happy to have a look.
>> >
>> >The partition table includes logs of hooley, with overlapping partitions
>> >and general mess.
>> >
>> >"reinstall" comes to mind. Fortunately, hda7 seems okay. I've copied it
>> >to another drive.
>> >
>> >I've looked around, everything seems to work, _but_ I don't see how or
>> >why I should trust it.
>> >
>> >Fortunately, "reinstall" was close to the top of the agenda for this
>> >box, and the main question was "with what?"
>> >
>> >Disk drive checks ok with smartctl and there are no errors logged to
>> >syslog.. Drive had about 345 power-on hours, shouldn't have expired yet.
>> >
>> >
>> >Choices are SL5, C5 and (possibly) Debian.
>> >
>> >Makes me wonder whether there might have been something unusual going on
>> >in your system,
>>
>> I have f8 (latest i386 respin dvd) installed on it now, and have about got
>> everything configured, but its been an interesting ride so far.
>>
>> One instant problem is bothering me, it appears that my kmail filters menu
>> survived the recovery from an amrecover session, but it is now immutable,
>> so I can't add some of the new aliases to a filter rule.  I can add them
>> to the filter screen, but when I click the apply button, anything I've
>> added is reverted to the original.
>>
>> Now, the weirdsville part is that I can open
>> the /root/.kde/share/config/kmailrc with less or vim, and the rules I've
>> added ARE there.
>>
>> That files perms are:
>> -rw------- 1 root root 99100 2008-01-05 22:31
>> /root/.kde/share/config/kmailrc
>>
>> Can someone else please do an ls -l on their file and show me what it has
>> for perms on your f8 machine that can successfully edit those filter
>> rules.
>>
>> I've nuked /root/kmailrc, and then restarted kmail as root, with no
>> visible effect.  The edits are lost the instant I click 'apply'
>>
>> Am I barking up the wrong tree here or what?
>>
>> Thanks John and to anybody else that wants to chime in with helpfull info
>> here, I'm plumb bumfuzzled from lack of sleep (a graveyard session at the
>> transmitter last night also turned into a nightmare) and this whole damned
>> zeroed out partition table fiasco.
>>
>> And as I add stuff back, selinux is being a PITA, so I may yet
>> touch /.autorelabel and reboot, but there are no messages about that above
>> file.  Nor are there any messages about it in setroubleshoot's display.
>
>----
>we've been down this lane before...you shouldn't use GUI as root

I've just spent 4 hours on the phone with the tv stations IT guy, trying to 
make it run for me like it does as root,  failed miserably.
>anyway...
>
>$ ls -l ~/.kde/share/config/kmailrc
>-rw------- 1 craig craig 113235 2007-11-25
>10:11 /home/craig/.kde/share/config/kmailrc
>
>yes, I would boot/relabel
>
>Craig

As in 'touch /.autorelabel' and reboot again.  I've had to fix a lot of 
setroubleshooter's output using semanage so the next relabel won't undo the 
chcon stuff it also recommends.

One of the bigger headaches is that as a user, I have no sudo rights, and I 
have added me by using visudo as root to add me.  But that isn't sticking, 
same error message the next time.

Plus its denying su for a command line I've been running in my rc.local file 
for years, 'su gene -c "fetchmail yadda yadda"'  but which once I'm logged in 
as root at runlevel 3, works perfectly.

I never had this much trouble with FC6.  Right now, I just ran amrecover to 
pull the /root/.kde tree back out of the FC6 based archive, which probably 
isn't a good deal at all, but at least kmail is working again even if it is 
as root.

Trying to add gene as an semanage sysadm also fails, dong it as root with the 
gui.  If this can't be fixed, then selinux will be disabled once again.

The su for fetchmail has been bz'd.
-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
I have ways of making money that you know nothing of.
		-- John D. Rockefeller


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]