[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: MP3 Players



Mr.Scrooge wrote:
> First and foremost my thanks too all who have responded to my
> request for MP3 info. Thanks very much. Now on to my problem child,
> you guessed it, heeeeerrrrrreeeeessssssss NANO Just testing the fix
> for new ipods and it is looking better but not good at this point. I
> was hoping to get some advice. Here is where i am with it :
>
> 1) Installed the libgpod 0.6.0 and gtkpod 99.12 from testing-updates
> 2) i was informed of additional dependencies for amarok and other
>    music players
> 3) I agreed and it downloaded and installed.
> 4) I hooked up newer ipod (it's mom's) to my F8 , it was not
>    immediately recognized like before

Perhaps there was some problem with the hal daemon?  It might be worth
looking in /var/log/messages and the output of dmesg | tail after
plugging in the ipod.  It definitely should be recognized and mounted.
There are also prefs for this that can disable automounting, but it
doesn't seem like you've intentionally done that.

> 5) I rebooted and it mounted. I opened amarok and connected. I
>    transferred music.
> 6) IPOD seemed to be responding, said it was synching ( i am feeling
>    giddy at this point)
> 7) Synch completed and i disconnected by unmounting . F8 reports
>    data being written to device.
> 8) F8 says now safe to remove. IPOD agrees says " ok to Disconnect"
> 9) IPOD reports used space properly but does not list music or play
>    it

That sounds like the needed info wasn't written to the iTunesDB.  This
should happen automatically with a program installed by libgpod that
is run by hal when the ipod is detected.  Either that didn't run
properly, which may be related to the ipod not mounting initially (as
in, something could be wrong with hal), or there could be some bug in
the libgpod hal callout.

Essentially, what needs to happen is that the FireWireGUID of the ipod
needs to get written to the ipod.  The hal callout tries to extract
this (and other useful) info from the ipod and write it to
/media/$IPOD_NAME/iPod_Control/Device/SysInfoExtended.  Can you take a
look and see if that file exists?  It should be an XML file and
somewhere in it should be an entry like:

<key>FireWireGUID</key>
<string>XXXXXXXXXXXXXXXX</string>

If the SysInfoExtended file does not exist, could you try running the
ipod-read-sysinfo-extended program?  You need to run this as root.
The usage is:

ipod-read-sysinfo-extended <device> <mountpoint>

For <device>, you want to use something like /dev/sdb (not either of
the partitions on the device).  For <mountpoint>, you use the
mountpoint of your ipod, something like /media/$IPOD_NAME.

That command should read the info from the device and create the
SysInfoExtended file.  If it fails to do so, please report any errors
it outputs.

> This is a 3rd Gen IPOD NANO Video - I tried the same with GTKPOD but
> no joy. Results the same. I should probably mention that before this
> i had tried synching the pod and when i was unsuccessful i synched
> it too an itunes to reset it. I knew of no other way, the logic was
> that then it would be factory condition and i could start
> experimenting anew. I think it might have updated the firmware from
> the original. So maybe i just screwed myself.

The updated firmware should be fine, AFAIK.  I believe it even fixes
some issues that folks had with the original firmware.

> Any Ideas?? Is there a way to do a hard reset that doesn't involve
> ITUNES?

I've used dd to backup and restore the first partition from my vfat
formatted ipod.  That's not really useful to reset the ipod though
unless you've backed up prior to updating the firmware.

-- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Truth is like a well-known whore.  Everybody knows her but it's
embarrassing to meet her in the street.
    -- Wolfgang Borchert

Attachment: pgpPN0fgvrYZ5.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]