[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HP restore clobers grub



Yes, I ran into it on my HP dv9000z, with SuSE 10.2.

I haven't tried it under Fedora, but basically you'd need to boot your
distribution CD/DVD into rescue mode, chroot to your Linux installation,
run Grub and reinstall grub on the drive in question. There are many
write-ups in the list archives, but it would be along the lines of:

grub> install (hd0)

Note that the syntax here installs the grub bootloader on the boot
block of the drive, NOT the partition. It might be a good idea to:

dd if=/dev/hd0 bs=512 count=1 of=/boot/grub/bootblock.orig

BEFORE you attempt the grub installation, to squirrel away a spare
copy of the original, pathetic, Windows boot block so that you can
always copy it back on in case something goes terribly wrong.

When I snarfed up my system, I let the HP Restore stuff do its thing,
waited until it was done and happy, then re-installed the grub boot block.
Everything performed normally thereafter; you can check the viability
of the Linux system bits by using the Rescue disk to boot it.

HTH,

Bayard

"Brake for Moose - it can save your life" - NHF&GD

Les <hlhowell pacbell net> wrote:
Hi, everyone,
I did get the a810n system loaded and apparently working, just an
occasional hang, and others are seeing that, so we will probably get
that sorted. My next problem is that HP put something in the windows XP
stuff that keeps wanting to "restore" the system, which in turn clobbers
grub. My best guess is that it wants XP to be the primary hard drive
(HDO). But I wanted it to be secondary, and I don't want grub
clobbered. A web search has not given me any useful information. The
HP website indicated something about removing the restore partition, but
without removing the offending bit that clobbers the boot, how would
removing a restore partition fix the problem without clobbering the
windows reboot? Anyway, the suggestion to remove the partition seemed
oriented toward reclaiming the diskspace, which is not my issue.

So, has anyone run into this, and what was the solution?

Regards,
Les H

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


Be a better friend, newshound, and know-it-all with Yahoo! Mobile. Try it now.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]