[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Pb with NFS



On Wed, Jan 09, 2008 at 10:29:14PM +0100, Francois wrote:
> Hi,
> 
> I try to finish the install of F8 on my new laptop, and now I have a problem 
> with NFS.
> I  have created the right exports file under /etc
> I have activated the NFS services as I used to do

> I can ping from my laptop to my main computer.
> I can't ping from my main computer to the laptop

Sounds like a routing issue. On both computers, please run (as root):

ifconfig
route -n

On each computer, see if you can resolve the host name of the other,
e.g. on fred:

host barney

and on barney

host fred

and copy and paste the results into an email.


> I've added the right entries in my /etc/fstab
> Now when I run mount mymaincomputer:/home
> I get : mount : mymaincomputer:/home failed, reason given by server : 
> permission denied.
> 
> When I do the same with my old laptop, it works fine.
> The old laptop and new one have the same IP, same hostname, etc... (of 
> course I run only once at a time ;-) )

That could also be your problem. NFS, ARP, and many other network
services will cache data for quite a long time. Try assigning the new
laptop a new, different IP address.


> I've tried to disable the firewall, but it doesn't help.

That is at best a short term solution. There have been discussions of
ways of dealing with firewalls recently on this list.

-- 

Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Attachment: signature.asc
Description: Digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]