[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Google Earth



Steve Siegfried wrote:
Antonio M wrote:
 and after latest (this morning) Xorg updates my GoogleEarth didn't
work any longer: I am waiting that Firefox will allow me to download
again GE and re-install (not sure which version is on my PC...) to
see.
Any way, I think that the problem is connected to drivers and not to GE.
I am using nv driver, now I have same problem, user is immediately
loggesd out as soon as it starts GE...



So if I've got this right, you:
	1- installed GoogleEarth and it worked
	2- updated Xorg stuff and GoogleEarth stopped working.

Lemme guess... you're running prelink, right?

There's something about the code in GoogleEarth that doesn't play well
with prelink... especially after upgrading libraries.

Try this:
	1- turn off (or remove) prelink
	2- remove GoogleEarth and re-install
	3- do an upgrade that includes libraries likely to be used by GE

Think you'll find that without prelink messing about in your bin and
lib directories, that GoogleEarth survives an upgrade.

You can pretty much prove that prelink is the culprit here by doing the
above 3 steps and then:
	4- reinstall prelink
	5- do another upgrade of some kind that includes libraries likely
	   to be used by GE
	6- leave the machine up for 48 hours so prelink can do it's stuff
	7- invoke GoogleEarth


Hope this helps,

FWIW, prelink is used here and google earth runs just fine....

If one wants to get a list of libraries used by google earth then all one needs to do is "ldd googleearth-bin" in the directory where GE is installed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]