[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[SOLVED!!] Re: can i completely delete and recreate my network interfaces?



On Sun, 13 Jan 2008, Robert P. J. Day wrote:

>
>   let's see if i can make a long story short.  for the sake of sheer
> experimentation, i wanted to see if i could *totally* remove all
> networking configuration from a gateway laptop running F8 x86_64, then
> use system-config-network (henceforth, s-c-n) to recreate it from
> scratch.
>
>   the underlying hardware (from lspci):
> ...
> 02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036
> PCI-E Fast Ethernet Controller (rev 10)
> ...
> 08:07.0 Network controller: Broadcom Corporation BCM4318 [AirForce One
> 54g] 802.11g Wireless LAN Controller (rev 02)
> ...
>
>   so i went into s-c-n, removed all traces of network configuration
> under both the Devices and Hardware tabs, saved that, removed the
> lines from /etc/modprobe.conf:
>
>   alias eth0 sky2          (um ... i think that's what it was)
>   alias wlan0 b43	   (added previously by me for wireless)
>
> i then unloaded the above modules from the system, and verified that
> the directory /etc/sysconfig/networking/devices is utterly empty.  so
> ... should i be able to put stuff back?
>
>   if i invoke s-c-n again, i'm not surprised to see both the Devices
> and Hardware tabs totally empty.  so how could i recreate the wired
> interface eth0?  if i try to add a new device of type "Ethernet
> Connection", i'm given only a choice of "Other Ethernet Card", and i
> don't see a corresponding entry for that ethernet controller.  should
> i?  or am i going about this the wrong way?  what would be the correct
> recipe to restore my eth0 interface?
>
>   i have just as little success trying to restore the wlan0 wireless
> interface, *until* i add the line
>
>   alias wlan0 b43
>
> back to /etc/modprobe.conf, at which point restoring the wireless
> interface via s-c-n is a piece of cake (it even handles the access
> point's WEP).
>
>   so wireless is back, but still no wired interface eth0, although i'm
> puzzled that the directory /etc/sysconfig/networking/devices now
> contains three files:
>
> ifcfg-eth0
> ifcfg-wlan0
> keys-wlan0
>
> and ifcfg-eth0 contains:
>
> # Intel Corporation PRO/100 VE Network Connection
> DEVICE=eth0
> BOOTPROTO=dhcp
> HWADDR=00:E0:B8:BF:7C:3F
> ONBOOT=yes
> TYPE=Ethernet
>
>   so what have i messed up?  is there, in fact, any way to restore
> eth0?  thanks.
>
> rday
> --

i apologize for rambling on so much this morning ... argh.  i'm not
sure this was the right solution but, based on what you can see in
my earlier posts, the broadcom wireless chip seemed absolutely
determined to grab control of both wlan0 and eth0.  so i just gave up
on eth0, and created /etc/sysconfig/networking/devices/ifcfg-eth1, and
added "alias eth1 sky2" to /etc/modprobe.conf, rebooted, ran s-c-n,
where, under "Hardware", i can now see an entry for the Marvell Fast
Ethernet Controller associated with eth1, and i can activate that
interface.

should i have known that?  is it normal behaviour for the b43 driver
to also grab eth0?  that's certainly not what i've seen on some of my
other systems.  is this a bug?  in any event, i'm not convinced this
is actually the *proper* fix, it's just *a* fix.  i need a drink.

rday
--

========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

Home page:                                         http://crashcourse.ca
Fedora Cookbook:    http://crashcourse.ca/wiki/index.php/Fedora_Cookbook
========================================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]