[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ipod



peter lesterhuis wrote:
> I followed the thread about the useability of ipods with linux. I
> just bought an ipod (nano 3rd gen, 4 Gb) for my daughter's birthday.
> When I connected the ipod to my box the filesystem of the hard disk
> was not recognized. I  rebooted into WinXP, which configured the
> filesystem into vfat. Back to fedora8 the ipod was being recognized:
> an icon appeared on the desktop, the mountpoint seemed to be
> /media/IPOD.  The problem is that I can't get gtkpod to load the
> ipod. When I start gtkpod this message pops up:
>
> Error initialising iPod: Couldn't find the iPod firewire ID
> Newly mounted iPod at '/media/IPOD' could not be loaded into gtkpod.
>
> The ipod is connected via usb, not firewire. Included with the ipod
> was only a cable with a usb-plug.  How can I get gtkpod to work,
> using this connection?  I tried amarok, but here the same problem.

The underlying problem is that libgpod (the library both amarok and
gtkpod use to read and write the ipod's database) can't seem to get
the (strangely named) FireWireGUID for the ipod.  This is needed to
properly write the database for all the newer ipods (nano video,
classic, touch, and iphone).

There is a tool in libgpod that ideally will run when the ipod is
connected and fetch this info from the ipod so that amarok, gtkpod,
etc, can properly write the db.  For some reason, that seems to not
have worked in your case.  If there's a reproducible bug there, I'd
love to help get it fixed.

As Richard suggested, it might be interesting to run  "tailf
/var/log/messages" and then plug the ipod in, to see if there are any
errors.

The other thing to try is to run ipod-read-sysinfo-extended.  The
arguments for the program are <dev> <mountpoint>.  The device will be
something like /dev/sdb.  You can look at the output of dmesg|tail
after you've plugged your ipod in to see what device name it has.  You
do want to use the raw device like sdb rather than sdb1 or sdb2, etc.
The mountpoint would be /media/IPOD in your case.  So the command
might be:

ipod-read-sysinfo-extended /dev/sdb /media/IPOD

That will attempt to read the FireWireGUID from the ipod and save it
as a file on the ipod so that amarok, gtkpod, and other libgpod using
apps can get at it easily.  If you get any errors running that, please
post them.

-- 
Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Remember the first rule of gunfighting..."Have a gun."
    -- Jeff Cooper, 1991

Attachment: pgpPZij7gzgh7.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]