[Fwd: LiveCD with KDE-4.0.0]

Andrew Parker andrewparker at bigfoot.com
Sun Jan 13 16:50:24 UTC 2008

2008/1/11 Rahul Sundaram <sundaram at fedoraproject.org>:
> Today is the release day of KDE 4.0.0. The packages should find their way into
> the repository soon or they are already there. What's missing is another live
> image to test the new stable version of KDE without the need of installing
> rawhide.
> http://www.fedoraforum.de/iso/test/rawhide-KDE4-i686-20080109/rawhide-KDE4-i686-20080109.4.iso
> http://www.fedoraforum.de/iso/test/rawhide-KDE4-i686-20080109/rawhide-KDE4-i686-20080109.4.sha1sum

On the whole, this is a lot more stable than the previous version I
tried (20071220), but it really doesn't take long to find problems.

The following are observations based on running from the Live CD.

>From the start menu (or whatever it is called now) and searching for
'konqueror' yields 4 apps called konqueror with no apparent difference
between them.

Starting konqueror gives yields a page "An error occurred while
loading file:///home/fedora/application/x-webarchive:  The file or
folder /home/fedora/application/x-webarchive dies bit exist."  (There
is no similar problem if you install from CD).

Using fish to save a doc (in kwrite) on another host fails as it picks
the wrong directory to save it in.  i.e. if you type fish://user@host
then use the folders to navigate to a different directory, it  tries
to save it in the root directory of the remote node.  You can specify
the complete filename manually, but the save just hangs.

One of the KTip tips states that dragging a file from konqueror onto
konsole will give you a choice pasting the URL or entering that
folder, but it only pastes the URL, no menu pops up.

Another KTip (yeah, I'm going through the KTips) suggests using kmag
with kruler to make measurement easier.  However, the arrow measuring
pointer in kruler does not get displayed in kmag, so it doesn't help.

The kruler menu (from right click) states that Ctrl-Q will quit, but
it doesn't.  In fact, none of the keyboard accelerators work for

Adding a widget to the LHS of the panel is impossible if the task
manager is on the left.  This is because trying to drag the widget to
the LHS raises the application, and you can't drop the widget on the
application.  Additionally there will always be a window there - the
add applet window.  In other words, if you remove the K menu, then try
to add it back where it was you can't unless you delete the task
manager first.

The default size of the task manager applet when added to the desktop
is way too small.  All you can see is a round black dot without any
tasks listed in it, unless you enlarge it by a factor of 10 or so.

The show percentage charged on the battery monitor applet only works
when the applet is on the desktop, not when its on the panel.

Warning, pedantic quibble ahead.  There is an inconsistency with "lock
widgets".  When you lock widgets, its not possible to bring up the
window to add new widgets - fair enough, the widgets are locked.
However, if the add widget window is already open, you can still add

The battery applet seems to display the battery charge from power up
as it never goes down.

The icon for the digital clock is an (analog) stop watch!

On completing a level in KBounce, the message displayed is too big for
the window, so you miss the beginning and end of the first line.

With the default theme its is very difficult to determine which window
is the active one.

The following are observations from installing the release:

On one host that I tried, installation from CD fails at the reboot with:

    mount: could not find filesystem '/dev/root'
    setuproot: moving /dev failed: No such file or directory

Firstboot does not give you the option of creating new users, so
you're forced to log in as root.

Creating a user via groupadd/useradd or via system-config-user then
logging in as that user results in the following error: "System policy
prevents PulseAudio from acquiring high-priority scheduling".  This
window is a nightmare to see as its obscured by the KDE splash screen,
then subsequently by KTip.  At this point, all clicks other than those
on the error window are ignored.  Given that KTip is always on top,
there is nothing a user can do (except ctrl-alt-f1, killall ktip,

On the new KMenu in the "Leave" page, clicking on logout brings up a
window asking if I want to log out/shutdown or reboot (but I have
already made my choice when I clicked on logout) so I'm forced to find
the same option again.  Presumably this is instead of a confirmation
window?  Its a similar problem for shutdown and reboot, except that
for shutdown the language on the second window is different (it says
"turn off computer").

If you want bugzillas on any of these then please let me know which
ones (some of these are so obvious that they must be well known).

More information about the fedora-list mailing list