[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Pulseaudio



Nigel Henry wrote:
On Sunday 13 January 2008 17:03, Karl Larsen wrote:
    Pulseaudio is an interesting old way to allow audio to be carried or
duplicated and perhaps other useful things. I am an Electrical Engineer
and studied the idea of mixing a lot of audio signals on a high
frequency. This is what Mr.Lennart Poettering  is trying to do with what
he calls Pulseaudio. I don't know just how it is done but it does work.

    I got Pulseaudio working on my Fedora 8 operating system and it
appeared to be working properly, but I didn't know enough about it to
test many features. But I did discover that two non-Fedora applications
called Skype and gMFSK will not function with Pulseaudio in operation.

    This problem I ask Lennart at Pulseaudio and he said this:

On Thu, 10.01.08 09:13, Karl Larsen (k5di zianet com) wrote:
 > >     I got pulseaudio working on F8 and the normal audio on movies and
 > > such is fine. But I tried gMFSK which is an application that uses the
 > > sound-card DSP engine. It looks fine but when I try to receive digital
 > > data it suffers very bad interference and it will not transmit because
 > > it says /dev/dsp is busy.

gMFSK seems to be a program that uses OSS (/dev/dsp) directly. For
those you have two options:

1) Use "padsp" to redirect it to PA. Just prefix your application call
   with "padsp".

2) Use "pasuspender" to temporarily tell PA to give up access to the
   audio device. This is probably the better way to fix this if you
   need lowest-possible latencies. (I am not sure if you need those,
   but I assume so, given this seems to be some modem sw?)

 > >     Sype comes up fine and appears to receive data but when I try to
 > > call anyone or answer a call they can't hear me at all, and all I hear
 > > is noise.

Skype is closed source software. It's very difficult to get this
working out of the box for you, due to its nature.

http://pulseaudio.org/wiki/PerfectSetup#Skype

Lennart

-- Lennart Poettering Red Hat, Inc. lennart [at] poettering [dot] net
ICQ# 11060553 http://0pointer.net/lennart/ GnuPG 0x1A015CC4
_______________________________________________ pulseaudio-discuss
mailing list

    I did both things and neither got my gMFSK or Skype working. There
is more to this than I have knowledge of.


    This problem caused me to delete all the pulseaudio from my F8
computer with yum remove *pulseaudio" which was a huge list! I did it
and nothing worked on the F8 system after that. I had to re-load F8 and
it came up working fine. But now, after removing the pulseaudio software
I cannot yum vlc from livna any more.

    Pulseaudio is a big error in my opinion. It does nothing a normal
user of Fedora wants but raises all kinds of issues with other software.
I really think Fedora needs to leave Pulseaudio off it's systems.

Karl

Hi Karl. Good evening (as it is in northern france).

It's never a good idea when Yum or Apt wants to remove half the operating system to just say yes, when you want to remove a package.

All you need to remove in the case of pulseaudio is the package "alsa-plugins-pulseaudio". If you are using KDE, this should also remove the KDE stuff for pulseaudio. I see that you are using VLC, and that uses SDL stuff, so you also need to add a line to /home/user/.bashrc, as below. unset SDL_AUDIODRIVER. Adding that line doesn't appear to affect playing DVD's though, as my DVD's play fine without that line.

I'll come back to the libx264 problems on your "updates" thread.

Al the best, and keep on trucking.

Nigel.



   Thanks Nigel. I guess the lesson learned is to not use yum to remove.


Karl


--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
  PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]