[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Updates



On Sun, 2008-01-13 at 16:30 -0700, Karl Larsen wrote:
> Craig White wrote:
> > On Sun, 2008-01-13 at 16:11 -0700, Karl Larsen wrote:
> >   
> >> Michael Schwendt wrote:
> >>     
> >>> On 13/01/2008, Karl Larsen <k5di zianet com> wrote:
> >>>   
> >>>       
> >>>>     It is a MAJOR problem. I can't load VLC and I might as well go to
> >>>> Windows if that is not working. Look back today and you will see the
> >>>> problem. Yum is updating files NOT on my F8!!!!
> >>>>
> >>>>     Can't yum vlc at all.
> >>>>     
> >>>>         
> >>> Show the result of some queries, please:
> >>>
> >>> $ yum whatprovides libx264.so.56
> >>>   
> >>>       
> >> [root localhost ~]# yum whatprovides libx264.so.56
> >> x264.i386 : Library for encoding and decoding H264/AVC video streams
> >> [root localhost ~]#
> >>
> >>
> >>     
> >>> $ rpm -qa 'x264*'
> >>>   
> >>>       
> >> [root localhost ~]# rpm -qa 'x264*'
> >> x264-0.0.0-0.3.20070529.fc7
> >>
> >>
> >>     
> >>> $ yum list x264
> >>>
> >>>   
> >>>       
> >> [root localhost ~]# yum list x264
> >> Installed Packages
> >> x264.i386                                0.0.0-0.3.20070529.fc7 
> >> installed      
> >> Available Packages
> >> x264.i386                                0-0.10.20070819.lvn8   livna    
> >>
> >>     Thanks for you help. It looks like it might be what is causing the 
> >> problem do you think?
> >>     
> > ----
> > what happens if you try...
> >
> > yum update x264
> >
> > ?
> >
> > Craig
> >
> >   
>     Hi I get this. Odd.
> 
> [root localhost ~]#
> [root localhost ~]#
> [root localhost ~]# yum update x264
> livna                     100% |=========================| 2.1 kB    
> 00:00    
> fedora                    100% |=========================| 2.1 kB    
> 00:00    
> updates                   100% |=========================| 2.3 kB    
> 00:00    
> Setting up Update Process
> Could not find update match for x264
> No Packages marked for Update
> [root localhost ~]# yum update x264-0.0.0-0.3.20070529.fc7
> Setting up Update Process
> Could not find update match for x264-0.0.0-0.3.20070529.fc7
> No Packages marked for Update
> [root localhost ~]#
> 
> So this is a real surprise too.
----
Not really... the 20070529.fc7 designation pretty much clinches the fact
that you have installed packages that were never intended for Fedora 8
but it's hard for me to determine how/where you got that from. Livna's
Fedora 7 repository has a much newer version which means that you
probably have more mess than that.

I suppose to see how badly you have things screwed up, you are going to
have to tell it

yum remove x264

and then get a list of what it's going to remove. Whether you say yes to
removing or not is up to you. You might want to put the list of things
yum wants to remove before you say yes or no.

Your call, your machine, your mess

Craig


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]