[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 hangs after 10 minutes inactivity on Dell optiplex 755



Ryan B. Lynch wrote:
Now that I think about it, I did have one of those pretty OpenGL screen savers selected. I can try the obvious thing, which is to switch to a blank screen saver, and a non-OpenGL screen saver, and see if there's a difference in the behavior.

If I can establish that the problem is, in fact, the OpenGL screen saver, that might also explain your (Keith Hunt) problem being intermittent. A lot of Fedora desktops I've seen have been set to random select a different screen saver each time it turns on--so sometimes you'd get an OpenGL one that screws the pooch, and other times it would be a non-OpenGL one that works just fine.

Too much speculation--when I get in front of that my Fedora machine, again, I'll keep digging and I'll see what I can find.

-Ryan


I triggered the locking behavior, ALT-F1'd to a text virtual console, and ran 'ps aux'. The program 'kdesktop_lock' was running, and when I gave it a 'kill -9' and ALT-F7'd back to the X session, everything was back to normal.

Initially, I tried opening the KDE control center to change the screen saver choice, but the screensaver plugin froze right after I selected it. I had to 'kill -9' the control center program. This is interesting, because that plugin automatically starts a minature demo of the currently-selected screensaver (which was, as I mentioned before, an OpenGL screensaver). I could not even change the screen saver selection.

I decided to try turning off the 'fglrx' stuff, and the easiest way was to back up my dual-head Xorg.conf file, remove the kernel module and X packages, and reboot. The machine came back up and everything worked (session locking, control center screensaver plugin, etc.) just fine. I switched to the 'slideshow' screensaver (non-OpenGL) to test the locking. Then, I re-installed the 'fglrx' packages, copied my dual-head Xorg.conf file back in place, and rebooted again.

The machine came back up with dual head working, and so I tested session locking. The screen successfully locked, but sometimes seemed to have a delay between the command to lock and the redrawing of the screen. The control center plugin crashed, though.

For now, I'm happy with this. I can lock the session and leave the idle -timeout lock turned on, and I can get control of the desktop back without the hassle of switching to a text console, logging in, and killing the lock process manually. That's enough to get my work done.

I suppose it could be something wrong with my dual-head Xorg.conf file--I never tried the screensaver with 'fglrx' running but no dual-head. I might try some more combinations, if I have the time, but right now it's just not a priority.

Keith, thanks a million for pointing me in the direction of the screensaver. That was the key, and I probably wouldn't have figured it out on my own.

-Ryan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]