[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Updates SOLVED!

Karl Larsen wrote:
Craig White wrote:
On Mon, 2008-01-14 at 23:56 +0800, Ed Greshko wrote:
Karl Larsen wrote:
Ed I have got past that.
Not sure what you've gotten past.
In fact I plan to try Tim's idea just to get a feel from part by part work. I thought the interplay between the two repos was the problem. It is not the problem.

Ahhh....OK...so you don't think having both livna and freshrpms enabled is a problem. I see...

Well then have fun. But, whatever you do, don't say "The Fedora XXX..." is at fault.

Tim, meet Karl.  Karl, meet Tim.
I solved that last night by going to bed.

I am particularly disappointed that you couldn't help Karl solve his


   OK the solution to my problem.

Step 1. I wanted to see what files from vlc are still on my computer. The method I wound up with was # rpm -e filename. I knew what files to delete from the list Nigel sent and it is:

The following extra packages will be installed:
  SDL_image (1.2.6-3.fc8)
  a52dec (0.7.4-8.fc7)
  faad2 (2.5-2.fc7)
  libcddb (1.3.0-2.fc8)
  libdvbpsi (0.1.5-2.fc7)
  libdvdnav (0.1.10-3.fc7)
  libdvdread (0.9.7-3.fc8)
  libebml (0.7.7-3.fc8)
  libid3tag (0.15.1b-4.fc8)
  libmatroska (0.8.1-2.fc8)
  libopendaap (0.4.0-2.fc7)
  libtar (1.2.11-9.fc8)
  libupnp (1.6.0-3.fc8)
  mpeg2dec (0.4.1-2.fc7)
  vcdimager (0.7.23-5.fc7)
  wxGTK (2.8.4-6.fc8)
  xosd (2.2.14-10.fc8)
From this list only libopendaap, mpeg2dec and wxGTK were NOT on my computer.

Now since I have just the freshrpms repo on my yum in /etc/yum.repo.d when I did # yum install vlc it did it perfect almost. The freshrpms repo is broken today. Here is what the download looks like at one part:

(13/20): vlc-0.8.6d-1.fc8 100% |=========================| 1.3 MB 00:49 http://ayo.ie.freshrpms.net/fedora/linux/8/i386/freshrpms/RPMS/vlc-0.8.6d-1.fc8.i386.rpm: [Errno -1] Package does not match intended download

It says it doesn't have the right vlc number or whatever. I thought maybe just a hickup and did this:

[root localhost ~]# yum --enable=freshrpms install vlc-0.8.6d-1.fc8.i386.rpm fedora 100% |=========================| 2.1 kB 00:00 updates 100% |=========================| 2.3 kB 00:00 freshrpms 100% |=========================| 2.1 kB 00:00 Setting up Install Process
Parsing package install arguments
No package vlc-0.8.6d-1.fc8.i386.rpm available.
Nothing to do

So in summary I fixed my problem by deleting all vlc files on my computer. I tried to load vlc from freshrpms and it is broken. Someone needs to fix it. I will try to fix it using the livna repo but I am going to be careful :-)


I tried using the livna repo without freshrpms being present and still get a problem from livna! And it is still the problem of livna wanting to update files not on my computer. Wierd!



	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
  PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]