[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Updates SOLVED!



Nigel Henry wrote:
On Monday 14 January 2008 19:50, Karl Larsen wrote:

    Now since I have just the freshrpms repo on my yum in
/etc/yum.repo.d when I did
# yum install vlc it did it perfect almost. The freshrpms repo is broken
today. Here is what the download looks like at one part:

(13/20): vlc-0.8.6d-1.fc8 100% |=========================| 1.3 MB
00:49
http://ayo.ie.freshrpms.net/fedora/linux/8/i386/freshrpms/RPMS/vlc-0.8.6d-1
.fc8.i386.rpm: [Errno -1] Package does not match intended download

    It says it doesn't have the right vlc number or whatever. I thought
maybe just a hickup and did this:

[root localhost ~]# yum --enable=freshrpms install
vlc-0.8.6d-1.fc8.i386.rpm
fedora                    100% |=========================| 2.1 kB
00:00
updates                   100% |=========================| 2.3 kB
00:00
freshrpms                 100% |=========================| 2.1 kB
00:00
Setting up Install Process
Parsing package install arguments
No package vlc-0.8.6d-1.fc8.i386.rpm available.
Nothing to do

    So in summary I fixed my problem by deleting all vlc files on my
computer. I tried to load vlc from freshrpms and it is broken. Someone
needs to fix it. I will try to fix it using the livna repo but I am
going to be careful :-)

Karl

Good evening Karl (at least it's evening here). I don't think there's a problem with the vlc package from freshrpms. The list I posted you was from when I installed it. The latest vlc I have installed is vlc-0.8.6d-1.fc8, and it installed and works ok. Check the link below for werewolf (F8), and the vlc entry that's there.

http://werewolf.freshrpms.net/

I don't know if your Yum is messed up somehow, but do you feel like a journey into the world of apt, and see if we can get your vlc reinstalled?

If so.
yum install apt synaptic

Synaptic is the GUI for Apt.

You need to add a line to /etc/apt/sources.list for freshrpms, as below.
rpm http://ayo.freshrpms.net/ fedora/linux/8/i386 freshrpms

For the sake of having a record of what's happened on the CLI, I'd also create a directory in your /home/user directory. Mine is named "History-files" . The edit tab on the terminal gives you the option to "save history as", and for normal system updates I name them according to the date. 20071118 as an example. If it's an install of a specific package with loads of deps like vlc, I'd name it as 20071118-vlc. It's nice to go back and see what was installed at the time. Anyway, enough of that, and presuming you are still game for trying out Apt to get your VLC fixed, we'll go for it.

Obviously su to root on the CLI, then type.
apt-get update

This will download the package lists for fedora updates, and everything (the defaults), and also from freshrpms (presuming you've added the line I mentioned)

Next, and just for the experience, type synaptic. This will open the Synaptic GUI, and you can scroll down to VLC, and see if it's available. Click on the line, select install. If there are deps needed, you will need to click on the "Mark" box. Then click on apply at the top of the synaptic window, which will open another window asking if you want to proceed with the install, and telling you the size of the download.

Putting Synaptic to one side, and after having done the apt-get update, you can simply type.
apt-get install vlc

To say the least, it will be interesting to see if apt-get has any problems with the vlc package, especially as you've had problems installing it with Yum.

Anyway it's getting late here, and I felt really hammered this morning after finding myself still posting at 3am last night. I'll be around for a while though.

All the best.

Nigel.

You I hope are already in bed but for others I am learning about apt-get. After getting it all set up, it ran looking for vlc on livna and said this:

[root localhost ~]# apt-get install vlc
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or that some of the repositories
in use are in an inconsistent state at the moment.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc: Depends: vlc-core
      Depends: libvlc.so.0

This seems to think the files are not in the proper order or are without a way to solve a dependencies.

This sure could be why yum fails too. I will add freshrpms to the mix and see what apt thinks about that.

Karl


--

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
  PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]