[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: livna problem



On Tuesday 15 January 2008, Karl Larsen wrote:
>     All you wise guys who are thinking your smart look at this and tell
> me what is wrong with my yum.

> GPG key retrieval failed: [Errno 5] OSError: [Errno 2] No such file or
> directory: '/etc/pki/rpm-gpg/RPM-GPG-KEY-livna'
> [root localhost ~]#

Reinstall the livna-release rpm to get the key.

> This is very bad indeed. I didn't recall vlc needing 41 rpm's

It needs more than that.  It needs what the packager and buildsystem says it 
needs; and unless the packaging is very broken it really does need all of 
that.

But, on my fully updated F8 install, I just installed it successfully, and it 
need to add 13 RPM's to what I already had (my system already has all the 
other RPM's in your list of 41 installed; also, I actually have Skype working 
with pulseaudio installed, but that's because skype is set up to use my USB 
Plantronics headset directly) (and, since I don't need vlc, I'll be removing 
it afterwards):

[root localhost ~]# yum install vlc
Loading "protect-packages" plugin
Loading "skip-broken" plugin
Loading "fastestmirror" plugin
Loading "upgrade-helper" plugin
Loading "allowdowngrade" plugin
Loading "downloadonly" plugin
Loading "presto" plugin
Loading "kernel-module" plugin
Loading "fedorakmod" plugin
Loading "changelog" plugin
Loading "priorities" plugin
Loading mirror speeds from cached hostfile
 * planetcore: ccrma.stanford.edu
 * livna: rpm.livna.org
 * fedora: mirror.anl.gov
 * planetccrma: ccrma.stanford.edu
 * updates: kdeforge.unl.edu
Setting up and reading Presto delta metadata
planetcore                100% |=========================| 1.9 kB    00:00
No Presto metadata available for planetcore
livna                     100% |=========================| 2.1 kB    00:00
No Presto metadata available for livna
fedora                    100% |=========================| 2.1 kB    00:00
No Presto metadata available for fedora
planetccrma               100% |=========================| 1.9 kB    00:00
No Presto metadata available for planetccrma
updates                   100% |=========================| 2.3 kB    00:00
No Presto metadata available for updates
primary.sqlite.bz2        100% |=========================| 190 kB    00:01
0 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package vlc.i386 0:0.8.6d-3.lvn8 set to be updated
--> Processing Dependency: libxosd.so.2 for package: vlc
--> Processing Dependency: libtar.so.1 for package: vlc
--> Processing Dependency: vlc-core for package: vlc
--> Processing Dependency: libaa.so.1 for package: vlc
--> Processing Dependency: libvlc.so.0 for package: vlc
--> Running transaction check
---> Package vlc-core.i386 0:0.8.6d-3.lvn8 set to be updated
--> Processing Dependency: libportaudio.so.2 for package: vlc-core
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc-core
--> Processing Dependency: libvgagl.so.1 for package: vlc-core
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc-core
--> Processing Dependency: libvga.so.1 for package: vlc-core
--> Processing Dependency: libupnp.so.3 for package: vlc-core
--> Processing Dependency: libmatroska.so.0 for package: vlc-core
--> Processing Dependency: libebml.so.0 for package: vlc-core
--> Processing Dependency: libdvbpsi.so.5 for package: vlc-core
--> Processing Dependency: libcddb.so.2 for package: vlc-core
---> Package xosd.i386 0:2.2.14-10.fc8 set to be updated
---> Package libtar.i386 0:1.2.11-9.fc8 set to be updated
---> Package aalib.i386 0:1.4.0-0.13.rc5.fc8 set to be updated
--> Running transaction check
---> Package libmatroska.i386 0:0.8.1-2.fc8 set to be updated
---> Package libupnp.i386 0:1.6.3-2.fc8 set to be updated
---> Package portaudio.i386 0:19-3.fc8 set to be updated
---> Package libcddb.i386 0:1.3.0-2.fc8 set to be updated
---> Package svgalib.i386 0:1.9.25-3.fc8 set to be updated
---> Package libebml.i386 0:0.7.7-3.fc8 set to be updated
---> Package dirac-libs.i386 0:0.8.0-2.fc8 set to be updated
---> Package libdvbpsi.i386 0:0.1.6-1.lvn8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 vlc                     i386       0.8.6d-3.lvn8    livna             3.3 M
Installing for dependencies:
 aalib                   i386       1.4.0-0.13.rc5.fc8  fedora             75 
k
 dirac-libs              i386       0.8.0-2.fc8      fedora            402 k
 libcddb                 i386       1.3.0-2.fc8      fedora             71 k
 libdvbpsi               i386       0.1.6-1.lvn8     livna              40 k
 libebml                 i386       0.7.7-3.fc8      fedora             73 k
 libmatroska             i386       0.8.1-2.fc8      fedora            203 k
 libtar                  i386       1.2.11-9.fc8     fedora             30 k
 libupnp                 i386       1.6.3-2.fc8      updates           101 k
 portaudio               i386       19-3.fc8         fedora             68 k
 svgalib                 i386       1.9.25-3.fc8     fedora            463 k
 vlc-core                i386       0.8.6d-3.lvn8    livna             3.2 M
 xosd                    i386       2.2.14-10.fc8    fedora             48 k

Transaction Summary
=============================================================================
Install     13 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 8.1 M
Is this ok [y/N]: y
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
(1/13): libdvbpsi-0.1.6-1 100% |=========================|  40 kB    00:00
(2/13): dirac-libs-0.8.0- 100% |=========================| 402 kB    00:04
(3/13): vlc-0.8.6d-3.lvn8 100% |=========================| 3.3 MB    00:22
(4/13): libebml-0.7.7-3.f 100% |=========================|  73 kB    00:00
(5/13): svgalib-1.9.25-3. 100% |=========================| 463 kB    00:05
(6/13): libtar-1.2.11-9.f 100% |=========================|  30 kB    00:00
(7/13): libcddb-1.3.0-2.f 100% |=========================|  71 kB    00:00
(8/13): portaudio-19-3.fc 100% |=========================|  68 kB    00:01
(9/13): aalib-1.4.0-0.13. 100% |=========================|  75 kB    00:00
(10/13): vlc-core-0.8.6d- 100% |=========================| 3.2 MB    00:21
(11/13): libupnp-1.6.3-2. 100% |=========================| 101 kB    00:00
(12/13): xosd-2.2.14-10.f 100% |=========================|  48 kB    00:00
(13/13): libmatroska-0.8. 100% |=========================| 203 kB    00:03
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: libebml                      ####################### [ 1/13]
  Installing: libmatroska                  ####################### [ 2/13]
  Installing: libdvbpsi                    ####################### [ 3/13]
  Installing: dirac-libs                   ####################### [ 4/13]
  Installing: svgalib                      ####################### [ 5/13]
  Installing: libtar                       ####################### [ 6/13]
  Installing: libcddb                      ####################### [ 7/13]
  Installing: portaudio                    ####################### [ 8/13]
  Installing: aalib                        ####################### [ 9/13]
  Installing: libupnp                      ####################### [10/13]
  Installing: vlc-core                     ####################### [11/13]
  Installing: xosd                         ####################### [12/13]
  Installing: vlc                          ####################### [13/13]

Installed: vlc.i386 0:0.8.6d-3.lvn8
Dependency Installed: aalib.i386 0:1.4.0-0.13.rc5.fc8 dirac-libs.i386 
0:0.8.0-2.fc8 libcddb.i386 0:1.3.0-2.fc8 libdvbpsi.i386 0:0.1.6-1.lvn8 
libebml.i386 0:0.7.7-3.fc8 libmatroska.i386 0:0.8.1-2.fc8 libtar.i386 
0:1.2.11-9.fc8 libupnp.i386 0:1.6.3-2.fc8 portaudio.i386 0:19-3.fc8 
svgalib.i386 0:1.9.25-3.fc8 vlc-core.i386 0:0.8.6d-3.lvn8 xosd.i386 
0:2.2.14-10.fc8
Complete!
[root localhost ~]# 

-- 
Lamar Owen
www.pari.edu


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]