[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update stuck !!!!



On Thu, 17 Jan 2008, Robert McBroom (TNWestTex) wrote:

> >
> > kusnux wrote:
> > Hi
> > i have a problem when i do a yum update. The result is :
> >
> > Total download size: 48 M
> > Is this ok [y/N]: y
> > Downloading Packages:
> > Running rpm_check_debug
> > ERROR with rpm_check_debug vs depsolve:
> > Package libdhcp needs libdhcp4client-3.0.5.so.0, this is not available.
> > Package nash needs libdhcp4client-3.0.5.so.0, this is not available.
> > Package mkinitrd needs libdhcp4client-3.0.5.so.0, this is not available.
> > ....
> > Complete!
> >
>
> Check for duplicate rpms installed.  Search the archives for a python script
>
> dupes-cli_py
>
> It is pretty good at cleaning up duplicates unless you have
> an x-64 system that has the 64 bit and 32 bit libraries out
> of synchronization.

do you really need a script to do that?  IIRC, a simple "rpm" query
will tell you that, as in (just for checking, not actual cleaning):

$ rpm -q kernel
kernel-2.6.23.8-63.fc8
kernel-2.6.23.9-85.fc8
$

as i've already suggested, we *really* need to see the output of, say:

$ cat /etc/fedora-release
$ rpm -q libdhcp
$ rpm -q nash
$ rpm -q mkinitrd

to see how those compare against what *should* be on a fully-updated
F8 system.

this *is* supposed to be an F8 system, right?  the OP still hasn't
confirmed that.

rday
--

========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

Home page:                                         http://crashcourse.ca
Fedora Cookbook:    http://crashcourse.ca/wiki/index.php/Fedora_Cookbook
========================================================================


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]