[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 8 64 bit X server issues



John Thompson wrote:
I have Fedora 8 x86_64 installed on a machine with on board Intel-945GM video. The xorg-x11-drv-i810 driver has been giving me a lot of problems: if I use it, I cannot access a text console using [ctrl-alt-Fn]; the monitor goes into standby with no display. The console still reponds to typed commands, but nothing is displayed on the monitor. On return to the X session, the display becomes unstable, and often dies, and won't let me log back in -- the gdm screen disappears and the "loading" cursor appears over a black screen, which persists indefinitely. I then have to change to a text console, log in (blindly) and initiate a reboot. On reboot, the POST text display is often wildly off-center unless I power off the machine for several minutes. I can use the vesa driver instead of the Intel driver, but then power management doesn't work. DPMS is enabled in the BIOS and in xorg.conf, but doesn't seem to be recognized by the vsea driver. If I try using e.g. GoogleEarth with the vesa driver, the X server just crashes.

What can I do to rectify this? Or should I just shit-can the on board video and get a separate video card?

My experiences with Intel graphics are generally poor, and it's nothing to do with amd-64 architected CPUs. After some fiddling, I have this working in my IBM Thinkcentre:

82865G Integrated Graphics Controller

OTOH I was wholly unsuccessful with this in a Dell Optiplex GX270:
82865G Integrated Graphics Device

This does not work well in my HP DC7700 SFF:
82Q963/Q965 Integrated Graphics Controller


I like to run xen-capable CPUs and this adds to the problems. First, with xen: I like to use a framebuffer console. It's a while since I tried on the Dell so we'll ignore that for the moment.

on the Thinkcentre, I boot with no special options for the kernel or module lines, vga=text-80x60 works for xen, but that's not good enough.
During running init scripts, I load intelfb
09:37 [summer numbat ~]$ cat /etc/sysconfig/modules/local.modules
#!/bin/sh
for i in intelfb ;do
        modprobe $i
done
09:37 [summer numbat ~]$ grep intelfb /etc/modprobe.conf
options intelfb mode=1280x1024 70
09:38 [summer numbat ~]$


That gets me a framebuffer on EL5-clone, whether I'm running xen or not.

On the HP, intelfb does not handle the graphics card, only the vesafb driver does, and that doesn't do framebuffer under xen.

The problems with these are minor compared with what I experienced on the Dell. Problems varied, and I had several different versions of Linux installed on it at the same time, SLES, OpenSUSE 10.0, RHEL5 client and server betas, FC6. I think it worked if I didn't use framebuffer, but if I did use framebuffer (and I don't think xen was necessarily part of the mix), then I tended to get video extreme corruption on the text consoles, and on FC6 X locked up when I switched back.

If a bit of fiddling with intelfb doesn't get results for you, then an alternative card sounds good to me.

--

Cheers
John

-- spambait
1aaaaaaa coco merseine nu  Z1aaaaaaa coco merseine nu
-- Advice
http://webfoot.com/advice/email.top.php
http://www.catb.org/~esr/faqs/smart-questions.html
http://support.microsoft.com/kb/555375

You cannot reply off-list:-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]