[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: I just wanted to burn a CD from a .iso



On 19/01/2008, D. Hugh Redelmeier <hugh mimosa com> wrote:
> I'm knee deep in bugs/problems.
>
> I just wanted to burn a .iso file to a CD.  (Why is another sad
> story.)  On my desktop F7 x86_64 system.
>
> I tried k3b, my normal tool.

There are alternative graphical burning programs, e.g. brasero. Just
in case you didn't know.

> Tools: Burn CD Image.  When I clicked
> "Start", it hung, not even updating the window damage.
>
> Why?  ps shows that it was hung awaiting a process doing lsof on /dev/sr0.
>
> strace showed that the lsof was doing a stat on an NFS mount point.  I
> have not idea why that would hang (but I could repeat it).  I have no
> ideas why lsof cared about the mount point.  Two more mysteries.

Well, k3b includes quite a complex filesystem browser, which does much
more than just displaying your home directory. If mounted fs are
inaccessible, that can cause problems then.

> I decided to burn the .iso using a script that I'd written a while
> back.  A wrapper for cdrecord.  That failed too.  It put out an
> endlessly repeating stream of warnings (with no newlines):
>
>     Unable to open this SCSI ID. Trying to map to old ATA syntax.This
>     workaround will disappear in the near future. Fix your
>     configuration.Unable to open this SCSI ID. Trying to map to old ATA
>     syntax.This workaround will disappear in the near future. Fix your
>     configuration.
>
> This script used to work on this machine.  I don't know when it
> stopped.  The actual cdrecord command was:
>   cdrecord -v dev=2,0,0 speed=8 -dao driveropts=burnfree --padsize=128k InitialHDD.iso
>
> The messages from that command, up until the repeated messages, were:
>     TOC Type: 1 = CD-ROM
>     scsidev: '2,0,0'
>     scsibus: 2 target: 0 lun: 0
>     WARNING: the deprecated pseudo SCSI syntax found as device
>     specification.
>     Support for that may cease in the future versions of wodim. For now,
>     the device will be mapped to a block device file where possible.
>     Run "wodim --devices" for details.
>
> Another mystery: what is wodim?  That one is easy: wodim is a fork of
> cdrecord.  So I was actually using wodim.

Fedora release notes covered that, IIRC.

> So: let's load the debuginfo package.  Even though wodim's rpm is in
> updates, the -debuginfo package is missing.  Another mystery.

How did you try to install it?
With "debuginfo-install"?

> This seems to suggest that dev=2,0,0 should be correct, but we already
> know it is not.  Another mystery.
>
> The cdrecord command worked when I used dev=/dev/scd0.

That device naming changes is covered in the release notes, isn't it?

> I decided, like a good citizen, to report the wodim problems.  It
> turns out that the bugzilla doesn't think that F7 has a "wodim"
> component, even though that is the name of the .rpm that it came in.
> Apparently cdrkit is the appropriate component name.  Another
> surprise.c

It's been like that for years and is explained on the bugzilla pages.
The "component" is the src.rpm package name. Don't use the "Expert"
bugzilla mode if you need the instructions.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]