[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HELP: External 250G USB screwed with GParted



Hi Mikkel,

2008/1/20 Mikkel L. Ellertson <mikkel infinity-ltd com>:
> André Costa wrote:
> >
> > I've read some reports about the same error messages suggesting they
> > could be caused by insufficient power on the USB ports (looks like it
> > really fluctuates, and that external drives demand more power than
> > usual USB devices). Initially I wouldn't consider this an option on my
> > case, since the drive already worked on this same port I am trying now
> > before the failed GParted session. However, I don't know if the drive
> > is now in a weird state in which more power is needed...
> >
> > WD sells a "power booster cable" for USD 9.99, but they only sell it
> > on the US =/ I'll try to buy a AC powered USB hub, this should ensure
> > all the power needed and get one variable out of the equation.
> >
> I have 2 2-1/2" USB drives that get their power from the USB bus.
> They both draw more power then one USB connection will easily
> supply. The computer end of the cable has 2 USB plugs, one that is
> only a power connection. To make the drives work right, you have to
> plug in the power-only plug first, wait 10 seconds for the drive to
> spin up, and then plug in the data connection. If you plug them in
> at the same time, or only use one plug, it will sometimes work, but
> it will usually have problems.

Thks for the tip. USB is trickier than I thought... all these
requirements takes all the fun out of it =/

> One other thing to keep in mind - if the drive drew too much power,
> the USB port may have shut down. I know some kernels enforce the
> power limits, but I don't remember if the current kernels do. There
> was debate about this, but I don't remember reading about the final
> decision. Moving to another USB port may fix the problem. (I don't
> remember how to reset the port.) This shotdown may also be BIOS
> dependent. On my laptop, I get overcurrent warnings when waking up
> under Windows sense updating the BIOS. I have not tested this under
> Linux yet.

Mmmh... didn't know about it. However, I've already rebooted the
machine a couple of times, and even booted it on WinXP. I also tried
some other ports, no luck. My guess is that the HDD got stuck into
some inconsistent state, which is in turn confusing the SATA --> USB
logic (don't even know if this makes sense). If that's the case, I
will have to open it up and plug the HDD directly to a SATA controller
to see if it's possible to do any kind of rescue procedure. I already
started looking for it on the web (this was encouraging:
http://www.youtube.com/watch?v=cQ0bgz3tyNk).

But, before doing that, I'll see if I can try an AC-powered USB hub,
so that I could really confirm that this is not the problem.

Thks for your help.

Regards,

Andre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]