[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: realplayer and pulseaudio on F8



Ian Malone wrote:

<on RealPlayer with pulseaudio on x86_64 Fedora 8>

So, I changed to a 32 bit build of RP.  I have it outputting
through a dmix device set to 48kHz as otherwise it runs
too fast (i.e. if I load a file on the machine it plays it back
at an incredible speed and a high pitch).  It now runs
okay both stand-alone and as a browser plugin.
However, because most things use pulseaudio now
(including flash and rhythmbox), using RP is mutually
exclusive with most other sound apps.


A little more on this:
I saw bug 338211 on the devel list, <https://bugzilla.redhat.com/show_bug.cgi?id=338211>.
The 32 bit version of alsa-plugins-pulseaudio is not
installed in x86_64, and this apparently causes
problems for 32 bit apps.  So I tried installing the
32 bit version.

It still doesn't work, but I get a different error now
(typed, not c&p)
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Progress of a sort (the previous error was a cannot open
shared library one for libasound_module_pcm_pulse.so).
I'm wondering if anyone using i686 F8 has RP working
with pulse (N.B. this is not RealPlayer 10 for Linux,
it's a build from helixcommunity based on the Helix 2
engine and works properly with Alsa otherwise).

As an aside, I was getting an error on starting RP about
the nodoka theme engine and it was looking particularly
un-themed.  Inspired by the above I tried installing the
32bit gtk-nodoka-engine, this appears to have stopped that
error and RP looks slightly nicer.

--
imalone


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]