[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: qemu access to the native CD-ROM on f8?



* Robert P. J. Day wrote, On 01/21/2008 09:23 PM:
On Mon, 21 Jan 2008, Andras Simon wrote:

On 1/21/08, Robert P. J. Day <rpjday crashcourse ca> wrote:
  i'm sure i'm screwing up something simple but i'm trying to use the
basic qemu PC system emulator and the linux image
"linux-0.2.img[.bz2]" here:

http://fabrice.bellard.free.fr/qemu/download.html

to access my native CD-ROM.

  it's a piece of cake to invoke the emulator thusly:

  $ qemu linux-0.2.img

and i can even see a reference to the "QEMU CD-ROM" go blazing by
during the boot process.  but after that ... nothing.

  the online qemu docs here:

http://fabrice.bellard.free.fr/qemu/qemu-doc.html#SEC20

*seem* to suggest that i should simply have access automatically via
the device file /dev/cdrom, but the qemu session has no such file.

  and the situation on the host system:

$ ls -l /dev/{cdrom,scd0,sr0}
lrwxrwxrwx  1 root root     3 2008-01-18 08:56 /dev/cdrom -> sr0
lrwxrwxrwx  1 root root     3 2008-01-18 08:56 /dev/scd0 -> sr0
brw-rw-rw-+ 1 root disk 11, 0 2008-01-18 08:56 /dev/sr0
$

  so i certainly seem to have sufficient device files on the host, and
the actual device file has world R/W access.  thoughts?
I think you should start qemu with

qemu -cdrom /dev/cdrom linux-0.2.img

i've tried that, and every variation of that i could think of
(/dev/sr0, /dev/scd0).  but, as i said earlier, i don't think the
"-cdrom" option is for assigning devices, i think it's for associating
*image files* with devices.  in any event, the above still doesn't
show me an available CD device from within QEMU.

that should work, read Invocation section carefully:
http://fabrice.bellard.free.fr/qemu/qemu-doc.html#TOC10

when you use -cdrom, the device always becomes /dev/hdc on guest, so -hdc and -cdrom options are mutually exclusive.

If you're still having problems, it could be related to Selinux security, check /var/log/audit/audit.log for related bits.



i'm wondering if it's related to the *type* of optical device -- this
is a dual-layer DVD burner.  would that somehow make it unrecognizable
as a simple CD device?  has *anyone* done this and got it to see the
CD device?

rday
--



========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

Home page:                                         http://crashcourse.ca
Fedora Cookbook:    http://crashcourse.ca/wiki/index.php/Fedora_Cookbook
========================================================================



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]