[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: totem question



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Gene Heskett wrote:
| On Monday 21 January 2008, Mikkel L. Ellertson wrote:
|> Gene Heskett wrote:
|>> I had enough livna troubles to last me a while when I was running FC6.  If
|>> I have to move outside the auspices of the rpm packagers, then I've found
|>> I'm far better off to just build the tarball and be done with it.  Which
|>> is what I did with mplayer itself, but not its plugin, which was
|>> available.
|>>
|>> Thanks Mikkel.
|> Rather then building directly from the source, you may want to
|> consider downloading the source RPM and building from that. That
|> way, you are still using the package manager. That way, it will
|> hopefully warn you when an update is going to break things.
|>
|> I have done this for a lot of packages. The only drawback is that
|> when you go to update, you may have to remove the packages yourself
|> before you can update to the next release of Fedora. It helps if you
|> keep a record of the packages you build, both to help when you
|> upgrade, and so you know what you are going to have to build again.
|> Because I build RPMs as a user, I normally have the ones I build in
|> my home directory, so it is easy. If I want to use the same version,
|> I just rebuild the package from the source RPM, using the updated
|> libraries. If not, the old spec file is a good place to start if I
|> can not get a source RPM for the new version.
|>
|> Mikkel
|
| Unforch, I have yet to come onto a tutorial on writing spec files that
| explains it in sufficient detail that _I_ can understand it.  If I want an
| rpm, I may use checkinstall, but its so bloody broken that by the time I
get
| a good rpm built with it, the spec file, and its dependency list are badly
| broken.  I built a gutenprint that ran my printer perfectly, but had to use
| smarts ability to freeze a version in place else the updates from FC6
| insisted on installing gimp-print-4.2.7, a 5 year old orphaned for the
last 4
| years package, over the top of it.  My printer is an antique Epson C82, but
| gimp-print-4.2.7 never heard of it other than as a generic.
|
| Now if someone were to write a tutorial on spec file's, starting at the
| McGuffy's Readers level, I MIGHT be able to do that.  If it exists, I
haven't
| found it, and I have asked here for guidance several times.
|
| Thanks Mikkel.
|


Does this help Gene?

Building Packages in Fedora
http://fedoraproject.org/wiki/Docs/Drafts/BuildingPackagesGuide

- --


~  David
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)

iEYEARECAAYFAkeVE/UACgkQAO0wNI1X4QEI5QCgjycdxfdRMCqSAEkWRVqKx0Eh
CoAAoLS6N66tRBKiLahBgOF291qS/RrW
=66yy
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]