[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VNC and native X display with vnc.so [Was: Re: more Fedora Cookbook: VNC]



Robert P. J. Day wrote:
On Tue, 22 Jan 2008, Les Mikesell wrote:

Robert P. J. Day wrote:
  on the server side i then restarted X (init 3; init 5) and, from the
client side:

  $ vncviewer 192.168.1.4:0

and, lo, i get a VNC window, but it looks like crap -- jagged
graphics, underneath which you can vaguely see that, yes, it is
trying to represent the remote desktop, and the remote control
does work but, clearly, i have some work to do here.
As I recall now, that's why I quit using it. I was getting one chunk
of the screen twice and the rest was fuzzy.  I think I got some
advice suggesting it was related to the underlying video card but I
gave up and haven't noticed any announcements saying it was fixed.

  i can appreciate that -- i've tried invoking vncviewer with various
encoding formats and such and the end result is the same -- massive,
stairstep-type jaggies to the point where you can *vaguely* see that
there's a desktop underneath, but it's utterly illegible.

  however, there is reason to be optimistic.  you referred to this
page for assistance:

http://forums.fedoraforum.org/showthread.php?t=162314

which recommends a whole *buttload* of changes and additions.

  as i mentioned, i got as far as i did with only the following
changes to the server's /etc/X11/xorg.conf (forgive me for repeating
myself):

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
        Option "SecurityTypes" "None"     <-- added this
EndSection

Section "Module"       <-- and these three lines
        Load "vnc"
EndSection

  i just wanted the absolutely minimal config that would get this
working.  and after restarting the X server, aside from the crappy
display, it does work -- on the client side, even though i can barely
see what's happening, i can look at the desktop on the server to
follow the action, and the mouse and the keyboard work perfectly.

  in short, i'm willing to believe that it's actually working
properly, i just need to figure out how to fix the display on the
client side from looking like crap.  and, on that note, i'll leave it
alone for now but i'll be happy to test any suggestions that come my
way.  after all, this really is a handy enough feature that it would
be a shame to get this close and not get it working fully.

rday

p.s.  depending on the web page i read, there are two suggestions for
loading the vnc.so module on the server:

first:

  Section "Module"
	Load "vnc"
  EndSection

second:

  Section "Module"
	SubSection "vnc"
		... vnc options ...
	EndSubSection
  EndSection

i know next to nothing about the xorg.conf file -- should i assume
that defining a SubSection in a "Module" section automatically implies
a "Load" of that module?

I just implemented this to share my F8 desktop (potoroo).

I restarted X, then connected using (real)vncviewer from tikanga-clone (numbat). The login screen came up blank (I could see the login screen at the next computer) so I moved over to investigate.

As soon as I started to do stuff, it came up on numbat.

The screens are the same dimensions, so I have a proper full screen on both, except that on numbat I seem to have a virtual screen somewhat (inches) deeper.

I tried also from my laptop, a Thinkpad (finch) with an internal screen 1440x1050 but also running another monitor at 1280x1024 so the screen slops around quite a bit on the external screen.

Performance (down a wireless link, up the same one then across another) was pretty shocking. Finch runs opensuse 10.2 and opensuse ships with tightvnc. After a few eons, the screen got drawn but the mouse cursor wouldn't move. tightvnc is prone to crashing, so I have that away.

btw I do believe that vncviewer example.lan::5900 works with tightvnc too.






--

Cheers
John

-- spambait
1aaaaaaa coco merseine nu  Z1aaaaaaa coco merseine nu
-- Advice
http://webfoot.com/advice/email.top.php
http://www.catb.org/~esr/faqs/smart-questions.html
http://support.microsoft.com/kb/555375

You cannot reply off-list:-)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]