[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [F8] Seems I lost my network connection...[SOLVED]



Daniel B. Thurman
>Ed Greshko wrote:
>>Daniel B. Thurman wrote:
>>> Ok, the steps worked and the modprobe -l showed
>>> exactly the right module.
>>> 
>>> The problem is, restarting netowrk did not bring it back.
>>> 
>>> I noticed the logs however and I see this:
>>> 
>>> kernel: IPv6 over IPv4 tunneling driver
>>> kernel: sit0: Disabled Privacy Extensions
>>> kernel: Attansic(R) l2 Ethernet Network Driver - version 1.0.40.2
>>> kernel: Copyright (c) 2006 Attansic Corporation
>>> kernel: net eth1: device rename sysfs_create_symlink failed (-17)
>>> udev:   renamed network interface eth1 to eth0
>>> kernel: net eth0: device rename sysfs_create_symlink failed (-17)
>>> kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
>>> avahi-daemon: Joining mDNS mulitcast group on interface 
>>eth0.IPv4 with address: 10.1.0.8
>>> avahi-daemon: New relevant interface eth0.IPv4 for mDNS
>>> avahi-daemon: Registering new address record for eth0.IPv4 for mDNS
>>
>>Hummm....never seen these types of messages....
>>
>>One thing you could try is running "system-config-network" and 
>>deleting/recreating the configuration.
>
>I did that several times.  Does not work.
>
>One thing to note here, is that this system is multiboot, so
>I tried w2kPro and XP and it works.  So I am convinced that
>somehow some package was installed that screwed it up or some
>kind of configuration is hosed.  I know for a fact that this
>onboard NIC is not the problem, nor the cable nor the switch
>the cable is connected to.
>
>So the next step was to re-install the HW PCI NIC as I had before
>for which eth0 was previously assigned to this card.  When I had
>successfully built the attansic l2 module, it was assigned eth1
>device.  Once I tested everything out, the attansic L2 was working
>good, I had shutdown the system and removed the HW PCI NIC card
>but not before I had removed both eth0 and eth1 from the
>system-config-network setting because I had forgotten about it.
>
>It wasn't until later when I had booted up and then removed these
>entries.  Ever since that, the udev was swapping eth1 for eth0
>but it worked so I ignored it. Maybe somehow the connections
>were made persistent - so when I lost the onboard NIC connection,
>I am left with a configuration mess that I have not been able to
>clean up?
>
>Anyway, when I reinstalled the HW NIC card, went into 
>system-config-network, and attempted to assign eth1 device to this
>NIC, instead it had automatically assigned dev4 to this NIC. I notice
>that the only devices available to me are: dev0, dev2, ... dev8.
>
>As we see in the above log message, udev attempts to reassign
>eth1 to eth0 but fails with a sysfs_create_symlink failure so
>perhaps there is a persistent configuration file somewhere OR
>there is another package that is taking control of the network.
>

I have solved my problems, so thanks to those who responded.

In summary, this is what I found:

1) As suggested, my cable was bad.  I just could not bring myself
   to believe it.  Somehow by adding the cable and the 2nd NIC,
   it was discovered that I added the bad cable and mixed it all
   up.  But not before testing in multiboot why all of a sudden
   even XP/2K was not connecting to the switch.  Also, there is
   one more monkey business to deal with: udev.

2) udev. Edited /etc/udev/rules.d/70-persistent-net.rules so that
   ethX assignments are in the correct order.  Changing via system-
   config-network does not seem to change this and caused confusion
   on bootup and in the dmesg logs especially if the 2nd NIC was
   removed later and udev wanted to "swap" eth1 for eth0 when eth0
   did not exist. It was definitately confusing.

3) The confusing auto-assignment of devices in system-config-network,
   that is, dev0-dev8 with weird extra numbers added such as
   network device: dev23546 threw me off.  What I did was to force
   via two hardware places, one in 'Devices' tab, profile-card, and
   the 'Harware Devices' tab, and the other in 'Harware' tab, on the
   right of 'Devices' tab.  It seems you have to select your NIC eth
   device selection via 'Hardware' tab, then go to the 'Devices' tab,
   select your NIC profile, click 'Hardware Devices' tab, and then
   click the dropdown list next to label: 'Harware' and select the
   new eth device assignment. Wierd.

Well, for now I am happy as a clam and my primary Attansic L2 on chip
NIC works and I still have my IntelPro NIC on standby in case I or
'acts of god' screws it all up again.  Sigh.

No virus found in this outgoing message.
Checked by AVG Free Edition. 
Version: 7.5.516 / Virus Database: 269.19.10/1240 - Release Date: 1/23/2008 5:47 PM
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]