[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Kernel release 2.6.23.14-107.fc8 and attansic L2 onboard NIC



Jonathan Dieter wrote:
>On Fri, 2008-01-25 at 08:10 -0800, Daniel B. Thurman wrote:
>> Sigh.  When is the Attansic L2 NIC code going to be installed in the
>> next release?  I have the "latest" source code I obtained 
>from the net
>> somewhere but this was for the previous kernel release.  Does the
>> fedora group have the source code and plan to compile this 
>into future
>> kernel releases?
>> 
>> I just got done making it work for the kernel 
>2.6.23.9-85.fc8 but for some
>> reason, the build for the new kernel 2.6.23.14-107 does 
>compile, does install
>> it in the correct lib/module place, but doing a 'modprobe 
>atl2' returns a failure:
>> 
>> FATAL: Error inserting atl2 
>(/lib/modules/2.6.23.14-107.fc8/kernel/drivers/net/
>> atl2/atl2.ko): Invalid module format.
>> 
>> What does this mean?  What do I need to do to make this work 
>for this new
>> kernel?
>
>Just a heads up that I've got it running just fine on the new kernel.
>Have you run depmod -a?  Did you have any error messages while building
>the module?

Thanks for responding quickly.  My mistake was that I forgot to
'make clean' first, before 'make install'

FYI: The make install automatically installs the mods to
/lib/modules/... and also does the /sbin/depmod -a. At Post
install, I did a modprobe -f atl2 and it worked.

Sorry for my mistake.  All is well!
Dan

No virus found in this outgoing message.
Checked by AVG Free Edition. 
Version: 7.5.516 / Virus Database: 269.19.11/1242 - Release Date: 1/24/2008 8:32 PM
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]