[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: old rpms after upgrade



> > Why does this happen?

One reason is because of missing 'obsoletes' definitions.

> > What should I do about it?
package-cleanup --orphans
(from yum-utils) will tell you about rpm packages that are installed that
aren't in any of your current repositories. Unless these are packages
you have added manually, you probably want to remove them.
package-cleanup --help
will tell you other things that it does. It is a very handy program to have
when a yum upgrade goes awry.

> Isn't this explained in the F8 release notes? It is normal, because
> not every package needs to be rebuilt for a new distribution release.
> Some are still binary compatible. Some are data packages. Some noarch,
> and so on.

It is normal to have some packages that have an extension that indicates
they were last rebuild for a previous version of Fedora, but you shouldn't
have orphaned packages. Also for f9 there is very likely to be a mass
rebuild as part of going to gcc 4.3 (assuming that actually happens) and
and you shouldn't see and packages with fc8 (or earlier) in the name.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]