[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[F8] Does eclipse work for you?



F8, Fedora's native Eclipse, v3.3.0

I am having a helluva time trying to get eclipse to work.  I had originally 
used the default eclipse installation when I installed the OS and running it 
came up at the time. As for updating Eclipse, I simply used Eclipse's 
software updater. But when I did that, I ran into conflicts especially 
dealing with Eclipse's 3.3.1 patches for which Fedora's eclipse is v3.3.0.  
What a nightmare.

On top of that, pup updated eclipse with Fedora's latest eclipse.  After that 
point, eclipse would not even start up.  It complains about PDE runtime being 
missing or broken as well as a whole raft of other problems.  Sigh.

Ok, ok.  I thought to myself that my eclipse installation must be hosed.  I 
will remove all traces of eclipse and start over and pray that 
re-installation of eclipse will somehow bring back the dead.

Well, after doing this remove and reinstall several times, playing around with 
different choices,  nothing I tried worked.

Some have said eclipse works for them. Well, it does not work for me. It won't 
even come up in it's basic installation by the package manager.  I tried to 
manually delete the places that package removal did not remove. In 
~/.eclipse, /usr/lib/eclipse. /usr/share/eclipse - everwhere I could find 
eclipse, I removed it and then reinstalled it.  Nothing worked - it could 
never come up.  The error dialog comes and and tells you that it left a log 
behind in your home eclipse directory. The log file is huge. It complains of 
PDE and a whole raft of other problems.  Oh, sorry, I am repeating myself.

Did anyone find out how to remove and successfull install and run eclipse?

Thanks-
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]