[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [F8] Does eclipse work for you?



Hi - I hate replying to top posted replies...

On Sat, 2008-01-26 at 16:09 -0600, Steve Strong wrote:
> me too.  here's what i did:
>       * i did NOT install fedora's versions of java and eclipse
>       * i installed sun's java jdk 1.6.3 and eclipse's Europa
>       * i changed my anacron job to exclude java and eclipse from being
>         updated with yum
>       * i used alternatives to make sun's java and javac versions the
>         "current best version"
> 
> and it seems to work.  good luck.  this is a mess that fedora could have
> prevented (IMYO)
> steve
> 
> On Sat, 2008-01-26 at 13:35 -0800, Dan Thurman wrote:
> > F8, Fedora's native Eclipse, v3.3.0
> > 
> > I am having a helluva time trying to get eclipse to work.  I had originally 
> > used the default eclipse installation when I installed the OS and running it 
> > came up at the time. As for updating Eclipse, I simply used Eclipse's 
> > software updater. But when I did that, I ran into conflicts especially 
> > dealing with Eclipse's 3.3.1 patches for which Fedora's eclipse is v3.3.0.  
> > What a nightmare.
> > 
> > On top of that, pup updated eclipse with Fedora's latest eclipse.  After that 
> > point, eclipse would not even start up.  It complains about PDE runtime being 
> > missing or broken as well as a whole raft of other problems.  Sigh.
> > 
> > Ok, ok.  I thought to myself that my eclipse installation must be hosed.  I 
> > will remove all traces of eclipse and start over and pray that 
> > re-installation of eclipse will somehow bring back the dead.
> > 
> > Well, after doing this remove and reinstall several times, playing around with 
> > different choices,  nothing I tried worked.
> > 
> > Some have said eclipse works for them. Well, it does not work for me. It won't 
> > even come up in it's basic installation by the package manager.  I tried to 
> > manually delete the places that package removal did not remove. In 
> > ~/.eclipse, /usr/lib/eclipse. /usr/share/eclipse - everwhere I could find 
> > eclipse, I removed it and then reinstalled it.  Nothing worked - it could 
> > never come up.  The error dialog comes and and tells you that it left a log 
> > behind in your home eclipse directory. The log file is huge. It complains of 
> > PDE and a whole raft of other problems.  Oh, sorry, I am repeating myself.
> > 
> > Did anyone find out how to remove and successfull install and run eclipse?
> > 
> > Thanks-
----
It's a good thing that not everyone thinks the same way that you do
because nothing would ever get fixed in Fedora using your methods.

This might be useful to OP
https://bugzilla.redhat.com/show_bug.cgi?id=409231

This might be useful to anyone trying to debug issues with F8 and
eclipse...
https://bugzilla.redhat.com/buglist.cgi?product=Fedora&version=8&component=eclipse&bug_status=NEW&bug_status=ASSIGNED&bug_status=NEEDINFO&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=CLOSED&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=

Craig


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]