[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: package manager problems: rpm db corruption|glibc detected double-linked|etc



David Timms wrote:
Hi, I started having trouble a few days ago with basic yum and rpm commands; they would seem to work, but finish with a Segmentation fault.
...

I've been having frequent problems with rpm database corruption. It doesn't happen every time, but maybe as often as 1/3 of the time I run 'yum update'.

However, I've not seen any segfaults or system-wide issues like you describe.

You can check the thread 'yum updates corrupting rpmdb', or http://permalink.gmane.org/gmane.linux.redhat.fedora.general/278481

You may find some hints, but no solutions there.

I've taken to running this to frequently verify the rpm database:

# (cd /var/lib/rpm && for f in `ls | grep -v '\.'`; do echo "$f"; /usr/lib/rpm/rpmdb_verify "$f"; done)

and using yumdownloader to get the update rpms, then running rpm by hand to install the packages a few at a time.

# yumdownloader `yum check-update | sed -e 's/ .*//' -e 's/\.\(i[3-6]86\|noarch\)$//'`
# rpm -Uvh [a-g]*.rpm
# rpm -Uvh [h-k]*.rpm
# rpm -Uvh [l-z]*.rpm
# rm *.rpm

And running the rpmdb_verify at points in there to check if things have gone badly.

So far, this has worked and I've seen no more corruption, but I can't make any conclusions about what causes the problem or if this procedure is preventing a problem, since absence of the problem is merely anecdotal.

It seems to me that I found that the rpmdb_verify would sometimes find errors even after a 'rpm --rebuilddb', so I no longer trust that alone to be sure the database is intact.

When the package system works, it works great. When it breaks, it's a steep climb to put it right.

<Joe


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]