[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libx264.so.56, where art thou?



On 29/01/2008, David Kramer <david thekramers net> wrote:
> I'm trying to get DVD and MP3 playing happening on my new f8 install.
>   I have  both working with mplayer, but mplayer doesn't appear to be
> able to navigate DVD menus.  I'm trying to install xine nonfree, because
> I know xine can do DVD menus.  When trying to install the xine nonfree
> package, or vlc, I get
> "Missing Dependency: libx264.so.56 is needed by package ffmpeg-libs"
>
> I've tried coming at it from a couple of different angles.  How can I
> get around this?

Look where your x264 package comes from. For example, don't mix
freshrpms and livna. They provide incompatible x264 packages that
upgrade each other in the wrong direction. Livna's package is seen as
_older_ as freshrpms' package due to its different package versioning
scheme, but it includes a newer and different library. libx264.so.55
vs. libx264.so.56 => that is the cause of your problems.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]